2

I am having a problem with the Lynx text browser. When I try to download a some tar.gz files, Lynx is not downloading it. It is putting it in a tmp directory and then trying to unpack it with the command:

/bin/tar tvf -

It does not always do this. Often it does just download the file, but if it is a link on a sourceforge site (one of those redirect "your download will start shortly" links), then it does the unwanted tvf behavior. Obviously this is wrong because it is GZIPPED file, so Lynx then hangs. The apparent reason it is doing this is that there is a line in /etc/mailcap that reads like this:

application/x-tar; /bin/tar tfv -; print=/bin/tar tvf - [etc, more gobblediguck]

This is doubly wrong because I don't want Lynx to put it in a tmp directory and unpack the file. I want it to download it to the current directory.

Ideally, I do not want to monkey with my mailcap settings, having no experience with such things. How can I get Lynx to just download tar.gz files when they are coming from sourceforge/auto download sites?

1

I have figured out how to deal with this problem without changing any MIME settings.

  1. Go to the page that has the download link

  2. Assuming you have the numbered link option on, set the cursor on the link using the "g" command. For example, if the link is numbered "[23]", type "23g" and press enter. If you just enter 23, then Lynx will try to download or otherwise activate the link. You don't want to do that. You just want to get your cursor to the link. If you do not use numbered links, then navigate the cursor to the link any way that you normally do.

  3. Press Shift+D, this will download the linked file to the current directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.