6

Hey Arch linux users out there!

I am new to arch linux( coming from ubuntu), and have just installed arch linux on my machine.

After rebooting I wanted to install some packages using pacman -S, but I saw that my machine wasn't able to fetch the files from the servers, I interrupted the installation ustn <Ctrl-C>. So I tried to update my repositorys using pacman -Sy, this didn't work because pacman wasn't able to fetch the packages.

So I tried to ping a few IPs, wich didn't work because

network is unreachable

After that I tried to set my eth0 up using

ip link set eth0 up

it returned me this error:

cannot find device "eth0"

the command ip link showed that lo (of course) and emp1s0(what the heck is that?) are up. I tried to set emp1s0 down using

ip link set emp1s0 down

wich returned

cannot find device "emp1s0"

I also tried to load the kernel module tg3 manually and to start dhcpd manually, both didn't work.

I actually do't know how to go on.

5
  • 2
    Read the Arch Wiki entry on networking...
    – jasonwryan
    Aug 8, 2014 at 10:46
  • @MattBianco It's emp1s0 Aug 8, 2014 at 11:03
  • @jasonwryan I rade that Aug 8, 2014 at 11:06
  • You don't have a "Fritz Box" router and windows on the same computer, do you? It would be nice if you could provide some output from the command ip a.
    – MattBianco
    Aug 8, 2014 at 11:22
  • 1
    don't know what I've done, but now It's working. Aug 8, 2014 at 11:37

2 Answers 2

5

Have you enabled and started systemd-networkd.service?

First create a file /etc/systemd/network/mynet.network containing (if you use DHCP):

[Match]
Name=device_name

[Network]
DHCP=yes

Then issue these commands:

systemctl enable systemd-networkd.service
systemctl start systemd-networkd.service

If that doesn't work (try rebooting aterwards in case you've been trying many things since last boot), boot from the install cd again and see what modules are loaded and try to find differences between the running environment when booting from harddisk and from cd.

The ArchLinux installation guide is a bit tricky to follow for first-time users. Some crucial information are not on the "first" page, such as network configuration and boot loader. In that respect, I find the gentoo handbook a lot more readable.

5
  • when running systemctl enable systemd-networkd.service it returns me the error code no such file or directory Aug 8, 2014 at 11:25
  • Have you removed the installation CD and booted from the hard drive? Did you install GRUB as a boot loader?
    – MattBianco
    Aug 8, 2014 at 11:28
  • yes and yes and I enabled Grub promt Aug 8, 2014 at 11:31
  • Have you logged in normally, then, or are you at a rescue/single user prompt? (can you switch tty with Alt-F1, Alt-F2 and so on?)
    – MattBianco
    Aug 8, 2014 at 11:32
  • I'm logged in as root on multi user mode (but runlevel returns unknown) but now it's working. Aug 8, 2014 at 11:40
3

emp1s0 is the new Consistent Network Device Naming name for eth0.

Use it where you would have used eth0 in the past and it will be fine.

It can be disabled if you insist on returning to eth0 by creating an empty:

/etc/udev/rules.d/80-net-name-slot.rules
5
  • ok, but why haven't I got internet acces? Aug 8, 2014 at 11:05
  • 1
    Don't know :-) Try posting the output of ip link, ip addr, ip route in your answer and people may be able to help. Aug 8, 2014 at 11:12
  • ip link see in my question;ip route:no output;ip addr only more output about lo Aug 8, 2014 at 11:29
  • "ok, but why haven't I got internet acces?" - because your config-scripts still assume that your NIC is called "eth0"? Aug 8, 2014 at 12:21
  • @countermode Hey! that was it! Aug 11, 2014 at 8:11

Not the answer you're looking for? Browse other questions tagged .