6

How can you hide unwanted apps from the gnome app menu?

I've installed alacarte/main menu, unticked the apps but they still appear.

I've also checked in /usr/share/applications and viewed one the apps I don't want to appear and it says NoDisplay=true but still it shows.

2
  • Hi don, spot on with the ~/.local/share/applications I found a few .desktop files in there. Also seems that it should be Hidden=true rather than NoDisplay=true which alacarte sets. Commented Aug 9, 2014 at 17:21
  • Tried both, neither works. Commented Aug 2, 2017 at 19:24

3 Answers 3

4

According to the FreeDesktop documentation (https://specifications.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.1.html) the correct option is NoDisplay=true for what you want to achieve.

Try to create a copy of an existing file from /usr/share/applications to ~/.local/share/applications (with a different name so that you can easily identify it) and set both options to see the behaviour.

0

The package menulibre provides the possibility to hide launchers with a simple switch:

gnome menu hide launcher

It's in french here, you'll find this option in your language

Do not forget to save your modifications with the following top-left icon:

menu libre save

0

I am in Gnome 43.2 (Manjaro).

For example, the Main Menu app itself, corresponding to the command alacarte, is displayed in Activities, in the Accessories subpanel.

This would instantly and brutally eliminate Main Menu from Activities:

% sudo mv /usr/share/applications/alacarte.desktop /usr/share/applications/alacarte.desktop-moved

which would be instantly reversed by

% sudo mv /usr/share/applications/alacarte.desktop-moved /usr/share/applications/alacarte.desktop

Usually you only want to customize your session. Even if you don't care about other users, you don't want your settings to be affected by operating system change (upgrade or switch to another Linux with Gnome).

As writen by cesar-rickinho, you can customize your session by copying /usr/share/applications/alacarte.desktop to ~/.local/share/applications. Gnome will give priority to your file over root's file.

You can open Main Menu in Activities or in Terminal with the command alacarte, click Accessories, see this.

Unticking Main Menu does nothing. I think it is a bug. But you can delete the item by clicking in the right column. This will not actually delete the file but only write in it "Hidden=true". Then, Main Menu is no more in Activities.

To restore the situation, you can delete "Hidden=true" directly in the file. Main Menu reappears instantly in Main Menu and in Activities, though outside the Accessories subpanel, possibly another bug, so you also need to drag it back to Accessories.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .