1

My centos version is:

2.6.32-131.17.1.el6.x86_64 #1 SMP Thu Oct 6 19:24:09 BST 2011 x86_64 x86_64 x86_64 GNU/Linux

And my ss version:

ss --version
ss utility, iproute2-ss091226

I need to update to version that I have on my Ubuntu machine :

ss --version
ss utility, iproute2-ss131122

How can I update the version (tried yum install ss)?

  • tried yum update? should update packages – RobSeg Aug 7 '14 at 9:43
  • I can't find ss in yum update and I don't want to update other packages, it is a production machine. – Amir Baron Aug 7 '14 at 9:46
  • ss is part of iproute package and its version must match the kernel version on the running system since they're simple user land tools that communicate with the kernel. If you're looking for some functionality that exists on newer versions it's quite probable (if not certain) that that functionality is simply missing from the kernel version you're running. – nkms Dec 13 '15 at 17:02
2

ss is not in a package called ss. If you run:

yum provides */ss

you will be shown a list of packages that provide the ss utility. A quick read through this will show that the package that provides ss is iproute.

You could possibly use a website such as http://rpmfind.net/linux/RPM/index.html to search for later versions of iptroute and install that.

The problem with this approach is that later packages will have dependencies that you don't have installed on CentOS 6. You will therefore need to install those too. After a while you'll end up with a hotchpotch system with various versions of utilities and libraries that haven't been thoroughly tested with each other which will only give you a great deal of pain, especially when you attempt an yum update later.

An alternative is to compile it yourself. There are various resources available on the internet. You can either compile and install, or you can compile and create an RPM which you then install on your system. However, compiling will necessitate the installation of many utilities and libraries on your system if you haven't compiled before.

Another option would be to use Copr build system to compile remotely for you. You create a src.rpm for iptables and send it to copr for building. Creating a src.rpm is relatively easy. Even easier, is editing already created src.rpm files from other systems, such as CentOS 7 or Feodra 20. Information on src.rpm is available from the Fedora Wiki, Fedora Docs and CentOS site and, of course, on Google.

Edit the .spec file within the src.rpm to reflect the version of the package you want to install, remembering that a certain version of a package (such as iproute) may well need certain version of other libraries installed. In this case, you'll end up in the same situation as if you'd downloaded the rpm from RPM Find.net above. However, using this method gives you slightly more control.

0

ss is provided by package iproute from the official RHEL rpm's repository. The latest version Red Hat provides is currently 2.6.32, which is the one you are using. You can find the latest sources at git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git . More info is available here. You probably have to compile it yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.