0

I am using Centos and I am installing one Debian application with multiple-instance.

I have created 3 multiple-instance successfully and it is running good.

Because of Debian application, the application is extracting in two different folders one is inside python folder i.e /usr/lib/python2.6/site-packages/openerp-7.0_20140802_231142-py2.6.egg/ and another one is inside home folder home/openerp2/openerp2.

This is two folder is created while extracting the file inside /home/openerp2 automatically.

My question is, I tried to creat 4th instance and tried to extract the file but it is extracting inside previous python folder i.e /usr/lib/python2.6/site-packages/openerp-7.0_20140802_231142-py2.6.egg/ and overwriting on it. By I am not able to do customization for that particular instance.

How to solve it?

2
  • 1
    its unclear what you are trying. Please mention how you untar and what is this instance thing about?
    – beginer
    Aug 7 '14 at 9:25
  • I have no idea what you're asking. What do you mean by “Debian application” and why are you installing one on CentOS? Do you mean that you're installing a deb package that you've converted to a tar with alien? What do you mean by “3 multiple-instance”, and what does this have to do with untarring? What does “untar to present date” mean? Aug 7 '14 at 21:17
2

When you untar, you can specify the destination directory by specifying the -C option:

/home/user>tar -xzvf test.tar.gz -C /home/user/destination/dir
1

Not sure to catch what you meant, however tar usually strip first / , so unless extracting from / you should have no problem.

 cd /data1 ; tar xf whaterver
 cd /datan ; tar xf whaterver

in your case, you end up with

/data1/usr/lib/python2.6/site-packages/openerp-7.0_20140802_231142-py2.6.egg/
/data1/home/openerp2/openerp2
/datan/usr/lib/python2.6/site-packages/openerp-7.0_20140802_231142-py2.6.egg/
/datan/home/openerp2/openerp2

Is this what you waont ?

Not the answer you're looking for? Browse other questions tagged or ask your own question.