2

The system detect my SD card but I can't mount it.

This is the lsblk:

my@my-N61Jq ~ $ lsblk

sdb                          8:16   1  29,3G  0 disk 

and the lsusb:

my@my-N61Jq ~ $ lsusb
Bus 001 Device 006: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader

Any solution?

blkid

my-N61Jq ~ # blkid
/dev/sda1: UUID="8cac68af-e4cf-4751-8137-43ebd72c7aee" TYPE="ext2" 
/dev/sda5: UUID="FcpGUy-5H07-e5kx-qM0Z-dUyS-MTju-REjs9M" TYPE="LVM2_member" 
/dev/mapper/mint--vg-root: UUID="dacda9a2-8b68-4ced-bd83-5f9e75c0e8fe" TYPE="ext4" 
/dev/mapper/mint--vg-swap_1: UUID="d9ba0894-a487-45cd-a8e4-a0b5e41ca147" TYPE="swap" 

closed as unclear what you're asking by roaima, Stephen Rauch, Jeff Schaller, Sparhawk, John Dec 22 '17 at 1:27

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you want an automatic mount? Have you tried doing a manual mount? It is quite straightforward. You need the output from blkid. – Faheem Mitha Aug 6 '14 at 17:06
  • I try to do manual mount but I cant: There is nothing in the blkid about sd card – kesivsk Aug 6 '14 at 17:21
  • Please add the procedure you are using to the question. – Faheem Mitha Aug 6 '14 at 17:23
  • 2
    Is formatted?Try cfdisk /dev/sdb and tell me what report(warning cfdisk is destructive command) open it and then after read quit without save.Another try to recognize a partition is partx or partprobe – elbarna Dec 24 '15 at 17:23
  • 1
    What does fdisk -l says? some cards show up as /dev/mmcblk* ; what does dmesg say when you insert/connect it? – Rui F Ribeiro Mar 29 '16 at 8:57
0

Here is an example, from my /etc/fstab

UUID="4E1AEA7B1AEA6007" /mnt/passport  auto    rw,user,noauto  0       0

You can use any mount point. Here I am using /mnt/passport. You find the UUID by using blkid. After you have added this to your /etc/fstab, run

mount pathname
  • Paste into the question, please. is your SD plugged in and turned on (if necessary)? – Faheem Mitha Aug 6 '14 at 17:35
  • Yes, my sd runs ok and is plugged in. – kesivsk Aug 6 '14 at 18:12
  • @kesivsk Strange. I've used various external USB mass storage devices, and blkid always detects them. Is it possible the SD card needs to be configured as a mass storage device? Have you tested in on another OS, eg OS X, Windows? Ok, on second thoughts, this is a multi-flash reader. Do you have a card plugged into the reader? – Faheem Mitha Aug 6 '14 at 18:18
  • is an internal card reader. I have tried with a lot of sd and no one is detected – kesivsk Aug 6 '14 at 18:30
  • Please clarify if this works with another OS. Have you tested it? – Faheem Mitha Aug 6 '14 at 18:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.