I just dual-booted windows 7 with Debian 7, during the installation it said the wifi firmware was missing so I installed without an internet connection, after the installation I got my LAN cable to install various programs but now i'm having problems configuring the wifi connection, on the windows partition wifi works fine.

So first thing I did was install the module for my wifi card, which is:

  Intel Centrino Advanced-N 6205 

I did it by installing iwlwifi on apt-get. After that it recognized my card, I think, because I could scan for the network:

root@debian:/home/user# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 7A:B6:86:83:0A:08
                    Frequency:2.412 GHz (Channel 1)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Extra: Last beacon: 2952ms ago
                    IE: Unknown: 00074E4554574F524B
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0100
                    IE: Unknown: 32040C183060
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B05010045127A
                    IE: Unknown: DD07000C4304000000
                    IE: Unknown: 0706434120010D10

I then installed iw to try to connect to the network:

root@debian:/home/user# iw dev wlan0 link
Connected to 7a:b6:86:83:0a:08 (on wlan0)
    freq: 2412
    RX: 33045 bytes (536 packets)
    TX: 1232 bytes (17 packets)
    signal: -59 dBm
    tx bitrate: 1.0 MBit/s

    bss flags:  short-preamble short-slot-time
    dtim period:    0
    beacon int: 100

It says i'm connected to the router, but I still don't have internet access.

Some more output:


root@debian:/home/user# ifconfig
eth0      Link encap:Ethernet  HWaddr 3c:d9:2b:25:51:cb  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::3ed9:2bff:fe25:51cb/64 Scope:Link
          RX packets:101484 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59551 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:139315514 (132.8 MiB)  TX bytes:5061083 (4.8 MiB)
          Interrupt:20 Memory:d1500000-d1520000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:343 errors:0 dropped:0 overruns:0 frame:0
          TX packets:343 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:30800 (30.0 KiB)  TX bytes:30800 (30.0 KiB)

wlan0     Link encap:Ethernet  HWaddr a0:88:b4:85:f5:cc  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::a288:b4ff:fe85:f5cc/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:297 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:26754 (26.1 KiB)


root@debian:/home/user# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=1884 ms
64 bytes from icmp_req=2 ttl=64 time=876 ms
64 bytes from icmp_req=3 ttl=64 time=0.813 ms
64 bytes from icmp_req=4 ttl=64 time=0.814 ms
64 bytes from icmp_req=5 ttl=64 time=0.845 ms
64 bytes from icmp_req=6 ttl=64 time=0.738 ms
64 bytes from icmp_req=7 ttl=64 time=0.737 ms
64 bytes from icmp_req=8 ttl=64 time=0.752 ms
64 bytes from icmp_req=9 ttl=64 time=0.830 ms
64 bytes from icmp_req=10 ttl=64 time=0.762 ms
64 bytes from icmp_req=11 ttl=64 time=0.768 ms
64 bytes from icmp_req=12 ttl=64 time=0.748 ms
64 bytes from icmp_req=13 ttl=64 time=0.784 ms
64 bytes from icmp_req=14 ttl=64 time=0.743 ms
--- ping statistics ---
14 packets transmitted, 14 received, 0% packet loss, time 13006ms
rtt min/avg/max/mdev = 0.737/197.826/1884.227/518.915 ms, pipe 2

root@debian:/home/user# ping
connect: Network is unreachable

I also noted I'm not getting an inet address when i connect to the router, only after i type dhclient wlan0:

root@debian:/home/user# dhclient wlan0
PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.984/0.984/0.984/0.000 ms

I do get an inet address. But still no internet, moreover, after getting the inet address pinging the router will output errors:

root@debian:/home/user# ping
PING ( 56(84) bytes of data.
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable
From icmp_seq=8 Destination Host Unreachable
From icmp_seq=17 Destination Host Unreachable
--- ping statistics ---
20 packets transmitted, 0 received, +4 errors, 100% packet loss, time 19120ms


root@debian:/home/user# ip route dev eth0  proto kernel  scope link  src dev wlan0  proto kernel  scope link  src 
root@debian:/home/user# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0 eth0     *        U     0      0        0 wlan0


Currently can't connect to the network at all:

root@debian:/home/user# ifconfig wlan0 up
root@debian:/home/user# iw dev wlan0 connect NETWORK keys 1:password
root@debian:/home/user# iw dev wlan0 link
Not connected.

I can still scan for the network though.

  • Can you ping your gateway? Probably but you'll need to confirm that. If that works, can you ping externally by IP address? Google's DNS server would be a good one - ping Post your results in your question. – garethTheRed Aug 6 '14 at 8:56
  • @garethTheRed done, the first ifconfig output was probably after i used dhclient wlan0. Since im not getting an ip automatically. – Jona Aug 6 '14 at 9:28
  • 1
    This suggests that your routing is incorrect. Check the output of route or ip route. The former should show you a line similar to default UG 1024 0 0 wlan0. – garethTheRed Aug 6 '14 at 9:39
  • Seems like you are right, any suggestions on fixing this? – Jona Aug 6 '14 at 9:50
  • @garethTheRed right, no default gateway. – beginer Aug 6 '14 at 9:56

You need to add the default route for your network. This is the 'catch-all' route that is used in the absence of a better one.

The command to add a default route is either:

route add default gw


ip route add default via

The above will not be permanent though.

To make it permanent, either add it to the network scripts in /etc/network/interfaces or use NetworkManager.

  • It did make my route command output like you said it should be, but still I couldn't use the internet (ping on the router also didnt work), so I rebooted to start over and try it again, but now I can't connect to the network at all, iw nor iwconfig let me connect to the network. – Jona Aug 6 '14 at 10:59
  • 1
    Are you using a Gnome desktop or similar? In which case, use Network Manager to configure it. There's even a nmcli utility to configure it on the command line on later versions. Have you installed the firmware-iwlwifi package? – garethTheRed Aug 6 '14 at 11:54
  • I am using openbox, i'll look into the different tools, thanks for all the help, I will report back when I can connect again. – Jona Aug 6 '14 at 12:47
  • I installed the Network Manager applet, (wicd didnt recognise my network) and it worked. I still don't know what was wrong with the cli method. – Jona Aug 6 '14 at 14:48
  • 1
    Glad you got it working - I'm not certain why your command line attempts failed neither. I've not used it much - usually only when X fails to start. – garethTheRed Aug 6 '14 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.