5

When I leave the mouse (Logitech Performance Mouse MX) alone, it moves (somewhat continuously) ever so slightly on its own! This causes several issues:

  • when watching a video full screen, the seek bar at the bottom never closes
  • screensaver/monitor sleep never activates

I'm running Debian Testing and the issue has been persisting for months now, so I assume it's something that is wrong with my setup (maybe I lack some essential packages?)

PS: I checked, there is no such issue on Windows, so it's not the mouse surface or something wrong with the mouse.

PPS: I've also tried solaar, but didn't help.

  • I sometimes have similar problems under Linux. I suppose that the Windows driver discards small moves. I wonder whether this can be done under Linux. Ditto for the mouse wheel, which is too sensitive with some mice. – vinc17 Aug 5 '14 at 20:44
  • 1
    Obvious question, but do you have this problem with a different mouse? – Faheem Mitha Aug 5 '14 at 21:48
  • @FaheemMitha I don't know. I don't have another mouse. – şaloma Aug 6 '14 at 7:36
  • 1
    I had this issue once and it turned out to be bad hardware. – Atul Aug 8 '14 at 21:06
  • Are you using the Touchscreen or it's configuration in Xorg ? Please provide your xorg.conf – SHW Aug 14 '14 at 6:18
5
+25

You can actually run tail -f on your mouse device file, this may change among kernels and distros but it should show you if your mouse is sending some irrelevant signals when it's not supposed to or vice versa.

The device file might be at the following location:

/dev/input/mice (Some tutorials confirm that this is the actual location of the file in Debian).

If you guys are aware of any other locations don't hesitate.

This file is not very comprehensible by humans and yet it's the only way to actually see the calls performed by your hardware.

Another possible option is to use the xev tool (bundled with some popular distros but you can install it if needed) which can read this rubbish coming from your /dev/input/mice file and show you the coordinates for example.

  • 1
    I'm running Fedora 20 and tail -f /dev/input/mice doesn't print anything. – Cristian Ciupitu Aug 12 '14 at 12:44
  • 1
    Yeah, that was the answer for Debian, on Red Hat based distros you better try /dev/input/mouse0 – Yaron Aug 13 '14 at 8:16
  • 1
    That seems to work, so +1 from me. – Cristian Ciupitu Aug 13 '14 at 11:03
  • 1
    Yes, I've actually experienced the same with my Arch, try using cat instead of tail -f – Yaron Aug 14 '14 at 21:21
  • 2
    okay. i've run cat /dev/input/mice and it spits out garbled chars. when the mouse pointer moves by itself it show one char. but how does this help me? i already know that the mouse moves by itself. – şaloma Aug 15 '14 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.