4

I have built pidgin from source on CentOS 7. This is because there is no package available yet. This went well, however, pidgin-otr-4.0.0 cannot find the headers for pidgin and purple.

They reside in /usr/local/include, and I can't work out what the configure script wants with its suggestion:

checking for EXTRA... configure: error: Package requirements (glib-2.0 >= 2.6 gtk+-2.0 >= 2.6 pidgin >= 2.0 purple >= 2.0) were not met:

No package 'pidgin' found
No package 'purple' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EXTRA_CFLAGS
and EXTRA_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I tried a variety of PKG_CONFIG_PATH options such as /usr/local and /usr/local/include, as well as EXTRA_LIBS. I am not sure what to do at this point.

I just need to specify somehow that pidgin and purple reside in /usr/local/include.

3
  • I found the answer: PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig ./configure
    – cyrus
    Commented Aug 5, 2014 at 21:50
  • If you found an answer, please add it as a answer. Thanks. Commented Aug 6, 2014 at 14:25
  • I'm new and I had not met the timeout to answer at the time of comment.
    – cyrus
    Commented Aug 7, 2014 at 9:23

3 Answers 3

3

I found the answer after having a second look at the pkg-config manual, and better understanding the purpose of those environment variables. I also noticed I could do a Google search for pidgin pkg-config. I was then able to find the solution.

This allows configure to find the required libraries with pkg-config...

$ PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig ./configure

This allowed it to find pidgin and purple.

0
2

I know this question is for CentOS, but since it was the first result I got when looking for Ubuntu, here are some Ubuntu 16.04 helpers.

I was missing pidgin, purple, gtk+-2.0

I needed to sudo apt install libgtk2.0-dev pidgin-dev libpurple-dev libgcrypt20-dev

1
  • Useful for me, but not the right answer.
    – Rutrus
    Commented Oct 13, 2019 at 14:07
0

Same error happened to me with pidgin-libnotify on RHEL 7.4.

This has resolved it for me:

sudo -i
yum install libnotify-devel
yum install libpurple-devel
yum install pidgin-devel
yum install gtk2-devel

env PKG_CONFIG_PATH=/usr/lib64/pkgconfig ./configure

(Do not use pkgconfig from lib64 - Although configuration will pass, it will fail later during compilation - with an unsigned int error).

./configure
make
make install

Now copy the generated plugin.so (in my case src/pidgin-libnotify.so) to your user .purple/plugins directory.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .