0

I installed Arch linux (I have reinstalled it a couple of times, actually, in the past 3 months, just to get to know it better).

My problem is, that I have 4GB RAM, and as soon as my free RAM hits 1GB (I have 3837MB RAM) and as soon as it hits exactly 1GB (like per MB, for example 2837MB and above) of free memory, my system starts to lag out. It becomes unresponsive for several minutes. As soon as I get it back above 1GB of free RAM, it suddenly becomes super responsive.

It doesnt matter what programs I have opened. Problem happens even on a clean install.

Extra info:

  • Arch linux (64BIT) the latest version
  • Have laptop Acer E1-572
  • Ram DDR3 1GB (one stick, but have place for 2)

What I have tried:

  • checked physical ram condition (ram is fully working)
  • tried another ram from the store (the same problem)
  • changed swappiness to 1 and then 0 (the same result)

I cant figure out what the problem is.

Like, 1GB should be plenty of space, right?

  • 1
    You say in separate parts of your question that you have 4GB and 1GB: which is it? You also don't mention your DE, or what applications you typically run when this happens... – jasonwryan Aug 5 '14 at 9:35
  • 1
    Sorry, let me clearify.. I have 4GB of ram. And issue happens, when my FREE ram hits 1GB and less. – ExClouds Aug 5 '14 at 10:14
  • Also. Im running Cinnemon. and it doesnt matter what apps i open. I tried to fill ram with terminal and text files, to test this. Happens even on fresh Arch install. – ExClouds Aug 5 '14 at 10:16
  • 1
    What are you using to measure free memory, and what else does it tell you? Oh, and how much swap do you have configured? – Useless Aug 5 '14 at 12:40
  • 1
    The description you're stating almost certainly sounds like your system is hitting swap on the HDD. I suspect you have even less memory than the < 1GB you say you're going below but without you providing the details of how you're measuring your system's resources your Q is almost impossible to help further w/ in its current form. – slm Aug 5 '14 at 13:18
0

Like @jasonwryan says, it's a bit unclear how much ram you really have, because you appear to have only 1GB via one single DDR3 stick. In which case the 4GB would be available through adding 3GB swap.

Also you say exactly 1GB (like per MB, for example 2837MB and above) of free memory but 2837 isn't 1GB? 1GB is 1024MB, 2GB is 2048MB etc...

Anyway, ignoring the discrepancies there I think you want to get a handle on which exact part of the system is suffering. For this I suggest you install and run atop.

Get a screenshot of the system working fine, and then a screenshot when it's misbehaving and add them to your question. That'll likely turn up the culprit or at least point us in the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.