2

I have followed this How To ( https://help.ubuntu.com/community/SettingUpNFSHowTo ).

My machine has a file system 30GB and other File System of 1TB mounted on /backup

As this How To says to create a /export and mount with --bind the folder you want on it, I did this:

Mounted the 1TB FS on /backup, mkdir /export, mounted --bind /backup /export.

then went to the client and mounted -nfs nfs_server:/export /nsf-backup.

but when I run df -h it says I have 30GB on /nfs-backup insted of 1TB, it is not recognizing that the 1TB FS is mounted on /backup. Am I missing something here? First time working with NFS.

client@host:~$ df -h
Filesystem                   Size  Used Avail Use% Mounted on
/dev/sda2                    138G   20G  112G  15% /
udev                         1.4G  4.0K  1.4G   1% /dev
tmpfs                        577M  1.2M  576M   1% /run
none                         5.0M     0  5.0M   0% /run/lock
none                         1.5G  156K  1.5G   1% /run/shm
/dev/sdb1                    597G  241G  356G  41% /extHD
nfs-server-IP:/export/backup   30G  896M   28G   4% /nfs-backup

root@nfs-server:/backup# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/xvda1       30G  896M   28G   4% /
none            4.0K     0  4.0K   0% /sys/fs/cgroup
udev            284M   12K  284M   1% /dev
tmpfs            59M  204K   59M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            295M     0  295M   0% /run/shm
none            100M     0  100M   0% /run/user
/dev/xvdf1      985G   14G  922G   2% /backup
11
  • Did you do the bind mount after exporting /export? If so, unmount the filesystem on the client, run exportfs -a on the server, and mount the filesystem on the client again. Aug 4, 2014 at 17:03
  • I've unmounted on the client and ran the command exportfs -a but it did not worked, still getting the 30GB FileSystem Aug 4, 2014 at 17:29
  • Are you sure, on the server, that /export is a mounted filesystem? I tried mount --bind /media/me/my-cd /export on an Ubuntu system, and after that, df shows /export in the list of mounted filesystems. But your df output above doesn't include /export. Aug 4, 2014 at 18:13
  • I did notice that also, it does not show /export as a mounted filesystem, that should be the error, but when I go to the /backup and create a test file, it appears at the /export. Aug 4, 2014 at 18:19
  • Can you paste the output of grep /export /proc/mounts and grep /backup /proc/mounts? I wonder if the filesystem type of /backup for some reason makes it so it cannot be exported. Aug 4, 2014 at 18:27

1 Answer 1

1

I had read about some cases in which the nohide option is needed (in the client side) in order to make the NFS clients capable of seeing binded folder/partitions in the server. I've never tried this option, but maybe you should take a look.

As a short resolution, i would export directly the 1TB FS. Whether mounting it directly over the /exports (mount /dev/hdX /exports -t <fs-type>), or mounting it in another location and exporting it. The detail is that you will need to add in your NFS configuration file /etc/exports the option crossmnt and reload the service with exportfs -r.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .