2

I was trying to debug an STunnel installation on my Raspberry Pi (using Raspbian) and so I set the foreground mode to yes (which is something suggested in the official documentation). Unfortunately, now every time the Raspberry Pi boots up, it will present the log to me in the foreground, with no way for me to run any other command, browse the file system, etc.

I tried Ctrl+Z, but that didn't work. The only thing that seems to work is Ctrl+Alt+Delete, but that just reboots the Raspberry Pi.

migrated from serverfault.com Aug 4 '14 at 16:33

This question came from our site for system and network administrators.

2

So, as stunnel is starting in foreground mode it's pausing the system startup process, so you're not presented with a login screen/UI?

I've not had much experience with raspbian, but there's a few things you could do to stop stunnel from starting so that you can change it's config:

  • Remove the sdcard from the raspberry pi and mount in another computer editing the startup script (probably the easiest if you've got another machine with an SD card slot); else
  • see if there's an interactive or rescue mode during boot, these should drop you into single user mode or enable you to stop the stunnel startup step completely.

Once you've got access to the root/startup files, I'd re-set the foreground mode again, probably in /etc/default/stunnel, /etc/stunnel.conf or perhaps even /etc/rc.local (if you'd added it in there manually).

1

I know on a regular Centos box a Ctrl + C will work. Not sure if it is the same for the Raspberry PI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy