0

I'm on RHEL 6.5 and Apache 2.2.15. And now applying a trusted SSL on the Server. After adding the respective SSL related Certs and files, my Apache is NOT starting up anymore.

Here are some outputs:

# apachectl configtest
Syntax OK
# service httpd fullstatus
ELinks: Connection refused
# service httpd start
Starting httpd:                    [FAILED]
# tail /var/log/httpd/error_log
[Mon Aug 04 17:57:08 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Aug 04 17:57:41 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Aug 04 18:03:31 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Aug 04 18:06:27 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

And when I do # tail /var/log/messages, there's no errors related to Apache or this operations.

What seems to be the problem, please? I have already turned off iptables and SELinux.

10
  • Are the certificate files readable by the apache user? Aug 4, 2014 at 10:23
  • In addition to @CristianCiupitu's suggestion. Do the certificates have the correct SELinux contexts? Maybe run the server with SELinux disabled to see if it helps narrow down the issue. Aug 4, 2014 at 10:26
  • @garethTheRed: "I have already turned off [...] SELinux". Aug 4, 2014 at 10:31
  • Hi @CristianCiupitu, those files need to be readable by apache? That means should give "r" to group. Is it supposed secure? Aug 4, 2014 at 10:32
  • And hi @garethTheRed as i mentioned above, SELINUX is already disabled (and even rebooted) Aug 4, 2014 at 10:33

2 Answers 2

1

service apache fullstatus is an alias for /usr/sbin/apachectl fullstatus. From the manual of apachectl:

fullstatus

Displays a full status report from mod_status. For this to work, you need to have mod_status enabled on your server and a text-based browser such as lynx available on your system. The URL used to access the status report can be set by editing the STATUSURL variable in the script.

It makes sense that fullstatus says the connection is refused: your apache is not running.

This fullstatus is not the reason something is wrong, it is just a symptom of apache not running.

0

I was also facing the same issue today. This is how I fixed the issue

~#cat /usr/local/apache2/logs/httpd.pid 
2322
~#ps aux |grep 2322
root   2322  0.0  0.0 81272 3396 ? Ss   Nov23 0:02 /usr/libexec/postfix/master
~#service postfix stop
Shutting down postfix:
~#/usr/local/apache2/bin/apachectl restart
httpd not running, trying to start
~#netstat -nlp |grep 80
tcp        0      0 :::80    :::*                        LISTEN      14549/httpd
~#service postfix start
Starting postfix:                                          [  OK  ]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .