1

I've installed MATE under Arch Linux. I've a problem with the shortcuts.

A lot of the shortcuts doesn't work so I tried to change them.

When I'm trying to reassign the shortcut I go to Settings -> Keybord Shortcuts, clicking the row I want to change and pressing the shortcut.

The problem is, when I press CTRL then ALT then L the command becomes: CTRL + L

If I change the order the buttons i press down the keys to ALT + CTRL + L the result is: ALT + L

So it looks like MATE only takes one of CTRL and ALT, the first one down, and not both of them as I want.

Does anyone have an idea why this could be?

It's not a new installation of Arch, but it is a new installation of MATE and Xorg.

  • Hmm. I just tested this under my installation of arch and mate (fully -Syu'd as of yesterday) and it works for me. Did you try both (right and left) of your CTRL/ALT keys? Could it be a keyboard failure? – hanetzer Aug 3 '14 at 18:18
  • Hi, It's the same if I using the right CTRL. I just tested installing GNOME 3 and there it worked, so it looks like there is a setting or other software issue in MATE. I Syu'd my Arch before installing MATE so it should be up to date. – Klamon Vadeen Aug 3 '14 at 18:22
  • Dunno then, but that's my two cents :P – hanetzer Aug 3 '14 at 18:25
1

I just found it.

I use CTRL + ALT to switch keyboard layouts. If I change that to something else, then all of the CTRL + ALT shortcuts work as they should.

Must be a bug then.

| improve this answer | |
  • Ah, like ibus or another input method editor? I typically use Super+Space, which is why I never ran into this issue. – hanetzer Aug 3 '14 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.