Microsoft has apparently decided to terminate the skype service for older versions (before current 4.3.0.37). That's too bad because I'm needing skype for work badly. Since I'm using an old Mandriva distribution (1) the last version that worked for me was 2.2.0.25 (2). I like this system since it's running smoothly, don't want to change it just for skype. Don't want to install a vmware machine either. So since yesterday I get an error message when I try to log in: server connection failed. Curiously, I briefly ran skype as root and then I could log in again, but not any longer. I then tried creating another user and ran skype from that. No luck. I suspect the server reads out the version of the skype client I'm running and then it refuses connection.

Or what is the mechanism here and can we circumvent it somehow? I thought immediately that one could possibly spoof version 4.3.0.37 making the server think I'm running this client and hence let me connect. Has anyone an idea how to concretely make this a reality? Any other ideas?

Linux version 2.6.31.13-desktop-1mnb (qateam@titan.mandriva.com) (gcc version 4.4.1 (GCC) ) #1 SMP Tue Apr 27 20:37:44 EDT 2010
skype-2.2.0.25-69.1mib2010.2.i686.rpm

PS: I need skype capability, not some other substitute service. The people I need to talk to only have skype and not the competency nor willingness to use another service.

PPS: What I've done now is build my very old desktop computer which is a duron 1 ghz machine with 386 mb sd ram. Installed Win XP on it + SP3. Installed skype which didn't work. Then another version of skype for "old pc's" was offered. Installed that and now I can place calls successfully. That's not my preferred solution though.

  • Did you try writing a wrapper that returns a different version string when called with --version and invokes the original skype executable otherwise? I doubt very much that this would circumvent their checks, but I've seen software fooled by less... – Joseph R. Aug 2 '14 at 23:12
  • I just did that quickly in C++. Doesn't work, as expected. – Chris Aug 3 '14 at 1:38
  • Why not upgrade and take advantage of all the fixed security problems in the old kernel/distribution you are using? It might even be faster! – mdpc Aug 3 '14 at 1:41
  • Did you try downloading from the Skype site and installing the latest version of Skype? – To Do Aug 3 '14 at 6:06
  • There is no version available for Mandriva. If I try to install the non-arch version I have so many dependencies to resolve, it would require a major upgrade of my system. Usually such upgrades result in a less stable system with numerous problems. Secondly, it's by far not guaranteed such an upgrade would make skype work for mandriva. It's rather unlikely. – Chris Aug 3 '14 at 12:22

Spoof to 4.3.0.37 version by exiting Skype and running the relevant command:

4.2.0.13 --> 4.3.0.37 Spoof (Tested Working)

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

2.2.0.25 -> 4.3.0.37 Spoof (Not Tested)

sudo sed -i "s/\x32\x2E\x32\x2E\x30\x2E\x32\x35/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

For other versions (Not Tested)

The version number to spoof from must be in this format X.X.X.XX because we will replace it with 4.3.0.37

Run the command below, replacing 4.2.0.13 with your Skype version number. This will output the replace command which you should then copy and run in a terminal like the method above:

ver=$(echo "4.2.0.13" | xxd -p | sed 's/.\{2\}/&\\x/g;s/^/\\x/;s/\\x0a\\x//'); echo "sudo sed -i \"s/$ver/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g\" /usr/bin/skype"

At the moment the Skype executable is sending the username, password and skype version to the Skype servers. If the Skype executable version is not at 4.3.0.37 then you will get the error Skype can't connect. All this fix does is replace that ASCII version number string e.g. "4.2.0.13" within the Skype executable to 4.3.0.37. Skype then allows you to login. I have only tested this on version 4.2.0.13, but I believe it should work on other versions too.

  • Unfortunately, the 2.2.0.25 binary doesn't contain a version string. Kind of good news however: 2.2.0.25 still works - on my Debian Wheezy box. On another box, also under Wheezy with the exact same skype-package and the same ~/.Skype/ folder, i get "Server connect failed" O_o – Themroc Aug 18 '14 at 20:14
  • After some time spoofed version stopped working for me. To reanimate it I had to install Skype 4.3, log in, and then rollback to 4.2.0.13. – aland Sep 24 '14 at 11:47

I doubt that you can spoof the version of skype in such a way as to allow you to connect. The most likely reason old versions are not supported is there was a non-backwards compatible change to its protocol, and Microsoft didn't want to support clients running the old protocol. The only way for this to succeed would be to replicate the new protocol (i.e. write a new skype client).

Maybe you can try Google Hangouts? (I did see you wanted to use skype, and not some substitute service, but I suspect this might be a reasonable replacement).

  • Agreed, spoofing is probably a waste of time, for the reasons you mentioned. – Faheem Mitha Sep 20 '14 at 9:15

phaoost wrote:

There is still a possibility to run older skype (4.2) - upgrade to 4.3 then login using autologin checkbox. Then quit skype and downgrade. I tried and it worked for 4.2. I am still seeking how to run 2.x version. I have found the above recipe on this link http://skype-open-source.blogspot.com/

Saintless answer:

For version 2x you need to add one line at the end of shared.xml: .....5. (Adding this line is needed for Skype 2.2 to work - Skype 4.2 will work without this step.) Open with text editor /root/.Skype/shared.xml and add one SavePassword

For more information, see here.

  • @phaoost , I have some troubles posting here proper code link. Read the link I gave. It explains proper how you still can use skype 2.2.0.35. code </Pos> <SavePassword>1</SavePassword> </UI> </config> – saintless Aug 26 '14 at 11:22

According to the Ubuntu forums, you can keep using Skype 2.2, you just need to remove the shared.xml file:

rm ~/.Skype/shared.*

protected by Community Oct 15 '14 at 9:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.