1

I am trying to debug my wifi which does not work so I want to stop wpa_suppliciant and apply the -d option

If I first

kill -9 <pid>

Then

ps -A | grep wpa

returns a new pid

I am on

Linux r4 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:12 UTC 2014 i686 i686 i686 GNU/Linux
  • You need to figure out who is bringing it up - eg NetworkManager, wicd, whatever - and stop that (can't tell you more because I don't have ubuntu at hand). – loreb Aug 2 '14 at 16:54
  • loreb's right, so I edited your title to more precisely reflect the issue. – goldilocks Aug 2 '14 at 17:02
1

Each time you kill WPA_supplicant a new instance is created by your connection manager.

You have to disable it before running the kill command. To disable the connection manager you need to stop the related service (I.e. network-manager, wicd, etc..) using the command:

service CONNECTION_MANAGER stop

Changing the string CONNECTION_MANAGER with the real service name.

After that you can execute the command you wrote but using an handwritten config file. You can use the command

man wpa_supplicant.conf 

to find examples or documentation about the configuration file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.