1

Yesterday, I have done some changes in /etc/sysconfig/network-scripts/ifcfg-eht0 in centos 6. I have edited the value of nm_controlled= "no" after "Yes".
Now, I am unable to see the "eth0" after doing ifconfig and lost internet and no ping .

1

nm_controlled="no" means that, that interface won't be controlled by the Network Manager. So now you may have to start the network service.

service network start

Also to get the service running on boot give the chkconfig

chkconfig network on

Also it would be better to edit the question and tell what you are actually trying to accomplish so that you may get the apt answers.

  • Actually,Last day ,I was trying to install the yum on my system,but I got some error.To resolve that error,I have edited the network configuration file as told by some other sites and change the value of NM_controlled=no. – Rohit Singh Aug 2 '14 at 6:57
  • Yes that was the case in older versions, I guess it was some bug and I hope you are using the latest CentOS6 and in that case you dont have to worry about NetworkManager and no need to give nm_controlled="no" . – beginer Aug 2 '14 at 7:04
  • Thank you!! But Now ,when I am going to change the value of nm_controlled="Yes"as default ,it only let me to change the value of nm_controlled ,but do not allow me to save the configuration file by command :wq! after setting the value of yes.That's exact problem . – Rohit Singh Aug 2 '14 at 7:10
  • ok, may be permission problem, use sudo. I think you should first check vim here at tldp. – beginer Aug 2 '14 at 7:14
  • Okay..Thanks ...Now I am able to see the my system ip address. – Rohit Singh Aug 2 '14 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.