1

I have a really strange issue with my Puppet Master.

I can't seem to get it to serve my manifests properly. I have installed manifests in two locations:

  • /etc/puppet/manifests/kungfumaster.mydomain.com.pp
  • /etc/puppet/environments/production/kungfumaster.mydomain.com.pp

Both of which contain something similar to this:

node "kungfumaster.mydomain.com" { 
    notify { "found the one in environments!": }
}

Neither of them run when I connect with my agent. The only one which is actually read appears to be /etc/puppet/manifests/site.pp, which does, in fact, run:

Notice: /Stage[main]/Main/Node[default]/Notify[thungs]/message: defined 'message' as 'thungs'

This node is defined like this:

node default { 
    notify { 'thungs': }
}

No matter how I've tried, I haven't been able to get these manifests to work properly, even when specifying a node default in the aforementioned files.

I'm seeing some strange logs emitted from my Puppet Master, but I'm not quite clear as to what they mean or how to solve the problem mentioned in them:

Jul 31 01:50:28 kungfumaster puppet-master[443]: Could not retrieve fact fqdn
Jul 31 01:50:28 kungfumaster puppet-master[443]: Could not retrieve fact ipaddress
Jul 31 01:50:28 kungfumaster puppet-master[443]: TrustedInformation expected a certificate, but none was given.

Configuration files:

Log files:

  • /var/log/syslog
  • Output of puppet apply --onetime --no-daemonize --debug --verbose: here
  • Output of puppet apply --onetime --no-daemonize --debug --verbose --environment production: here

The Puppet Agent and Puppet Master are both on the exact same host.

The strange message about expecting a certificate is generated here: https://j.mp/1zxG08Q

3

You do not have the manifest parameter set in your puppet.conf, meaning it defaults to /etc/puppet/manifests/site.pp.

If you instead change it to /etc/puppet/manifests, puppet will pull in every file in that directory.

So basically add the following to your config:

[main]
manifest = $manifestdir

($manifestdir defaults to /etc/puppet/manifests)

  • This actually work, but when I run puppet agent --test on the master machine I get this warning: "Warning: Setting manifest is deprecated in puppet.conf." Any clue? – Fabrizio Regini Oct 15 '14 at 11:59
  • Not off hand no. I haven't been keeping up with the latest puppet releases. Best bet is to just consult the docs on the parameter and see what's going on. – Patrick Oct 15 '14 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.