4

I'm running a CentOS 7 install in VMWare Workstation 9. I have removed the floppy drive from the VM configuration (as my host machine does not have one, and I haven't used one in literally 12 years).

When the VM boots, an error message comes up:

end_request I/O error dev fd0 sector 0

The error does not halt the machine from running, but i would like to deal with the issue.

After looking around online, it seems that the floppy module is loaded at start up by default, whether there is a floppy drive connected or not. This can be disabled by telling the system not to load the module at start up, and apparently the different flavours of GNU Linux all have different ways of doing this. I've tried several methods, and all have failed as the module still loads on start up and the same error message still appears during boot. I've tried adding the following line to each corresponding file:

/etc/modprobe.conf:

alias floppy off

/etc/modprobe.d/blacklist.conf:

blacklist floppy

/etc/modprobe.d/floppy.conf:

blacklist floppy

In each case those files did not exist as default and needed to be created, and thus far every method has failed. Does anyone have a definitive answer for how to disable the floppy module from loading on boot in CentOS 7 specifically?

I have asked on the CentOS 7 forums, but there has not been any reply, hence me asking here instead. Please note that the solution for CentOS 6.5 does not work.

  • What is "the solution for CentOS 6.5"? – Faheem Mitha Jul 30 '14 at 10:03
2

I was able to disable floppy module from loading by adding this two files:

/etc/dracut.conf.d/nofloppy.conf
    omit_drivers+="floppy"

and

/etc/modprobe.d/nofloppy.conf
    blacklist floppy
1

Not elegant, but you can disable it with a kernel line boot option

modprobe.blacklist=floppy

in either your grub append line or extlinux.conf append line

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.