You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 fglrx-driver : Depends: libfglrx (= 1:14.4.2-1kali1) but it is not going to be installed
 gmail-notify : Depends: python-eggtrayicon but it is not going to be installed
 libgl1-fglrx-glx : Depends: libfglrx (= 1:14.4.2-1kali1) but it is not going to be installed
 libgl1-fglrx-glx:i386 : Depends: libfglrx:i386 (= 1:14.4.2-1kali1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I don't want to install these packages anymore (they are not compatible with my graphics unit). And so I do not need to install their dependencies using apt-get -f install (as it is suggesting).

What is the way to get rid of these packages and this unmet dependency problem? (I tried apt-get autoclean && apt-get autoremove).


The best way to remove such unmet dependencies that you do not want to satisfy is to use:

apt-get purge

Purge ensures that any configuration files in relation to the package are deleted as well. In short, purge would remove anything in relation to the package--and you would be rid of the unmet dependency problem.


At first sight, I would say that the packages are installed.

So if you don't want them anymore, just remove them:

apt-get remove fglrx-driver gmail-notify libgl1-fglrx-glx libgl1-fglrx-glx:i386

(Maybe with a -f flag to pass the dependency check.)

  • Thank you for your quick response. I did try apt-get remove ... but that didn't work. However I forgot about apt-get purge!! I just tried it and it worked. Posting the solution now! – learnerX Jul 29 '14 at 10:20

Just remove the install-info package.

After two days of "computer hell", I finally got the answer. It wasn't easy! Uninstall it from synaptic package manager, or from terminal.

sudo apt-get remove install-info

I recently upgraded from Xubuntu 14.04 to 14.10, then immediately to 15.04.

BOTH TIMES I got the "unmet dependencies" and "held broken packages" errors and had to remove the install-info package. (Glad it wasn't a System file.)

It's an absolute curse to Linux! I don't know which is worse; fixing a rootkit in Windows, or finding this bug in Ubuntu!


This can be caused by improperly-built custom packages with unnecessary dependencies. In that case, you can edit the pkg database and remove the unnecessary dependency.

Don't edit the package database unless you're absolutely sure of what you're doing, and that the dependency really, truly is unneeded.

vim /var/lib/dpkg/{status,available}
and remove the troubling dependency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.