5

In Chrome 35.0.1916.153 or 36.0.1985.125, sometimes, my Compose key partially doesn't work. As far as I can tell, combinations whose last character uses the Shift key that don't work. For example, 'eé and /= work but not 'EÉ or ->. In this post, when I say that a combination doesn't work, I mean that nothing happens when I press it; for example, pressing a Compose ' e b inserts ab.

In my running instance, if I type Compose ' e, this inserts the character é, as it should be. But if I type Compose ' Shift+e, nothing happens. The same goes in an incognito window that I already have open. However, if I open a new incognito window in that instance, Compose ' Shift+e inserts É as it should at first, but as soon as I open a web page, combinations ending in a shifted key stop working. The same goes with another user account with a fresh profile: 'EÉ only works until I load a web page.

This problem didn't start today. I don't remember if it started when I upgraded from Chrome 34.x (stable) to Chrome 35.x (stable), but it started around that time.

I normally have the environment variable GTK_IM_MODULE=xim, because I don't want Gtk applications to use an input method different from standard X applications. Removing this variable for Chrome seems to make Compose work normally.

What is the effect of GTK_IM_MODULE on Chrome? How do I get it to reliably use the X11 input method?

closed as off-topic by Gilles, slm Dec 23 '14 at 21:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Gilles, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I have 38.x version, and these combinations works fine. You have to try to set the xim with the im-config application. I had GTK_IM_MODULE=xim as well with some other options, and it worked wrong. I guess the im-config sets some variable besides these ones. – Hi-Angel Nov 9 '14 at 12:08
  • I haven't seen this bug for a while, since I upgraded to Chrome 38 I think. I'm going to guess that this was a bug introduced in Chrome 35 and fixed in 37 or 38. – Gilles Dec 23 '14 at 20:52