0

. . . And how can I fix that? :-) I'm running RHEL 5 and when I try to view man pages as a regular user, they are blank. I've tried man man > manman.txt; cat manman.txt and there is no output, i.e., the file has no length. I try sudo man man and I see beautiful man page output.

I've looked at the permissions under /usr/share/man and they look okay. The directories are all o+rwx and the files are o+r.

I've tried . . .

[me@host01 ~]$ sudo man -w man
/usr/share/man/en/man1/man.1.gz
[me@host01 ~]$ man /usr/share/man/en/man1/man.1.gz

. . . and that's blank also.

  • Does e.g. man su work for you? – Faheem Mitha Jul 28 '14 at 21:35
  • @FaheemMitha Nope. That's blank also. – hourback Jul 28 '14 at 21:36
  • As a non-root user, what does zcat /usr/share/man/en/man1/man.1.gz produce? A man page or an error message? – Mark Plotnick Jul 28 '14 at 21:48
  • 2
    Sounds like you've messed up the environment variables for the pager that man uses to display its contents. unix.stackexchange.com/questions/23394/… – slm Jul 28 '14 at 22:48
  • 1
    I agree with slm. Try man -M /usr/share/man/en/man1 man and see if that works. If it does, then your MANPATH isn't properly defined for your regular user. – Warwick Jul 28 '14 at 23:36
1

I have to give this one to my co-worker who discovered that the permissions on /tmp were incorrect:

[user@host01 ~]$ ls -ld /tmp
drwxr-xr-x 7 root root 4096 Jul 28 18:44 /tmp

And we know they should be set with 1777:
[root@host01 ~]# ls -ld /tmp
drwxrwxrwt 7 root root 4096 Jul 28 18:44 /tmp

Found this out when I tried to run nroff.
[user@host01 ~]$ nroff
mktemp: cannot create temp file /tmp/man.n10337: Permission denied
/usr/bin/nroff: line 50: ${TMPFILE}: ambiguous redirect
XXX
XXX WARNING: old character encoding and/or character set
XXX

Now, I'm really stumped as to how that happened! But anyway. . . .

Thank you for all of the good comments, folks! You've helped me learn more about how man pages work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.