6

I'm trying to use Dolphin as file chooser for Firefox in Archlinux instead of Nautilus. I've read this but it did not solve my problem. The config seems related to firefox as

xdg-mime query default inode/directory
dolphin.desktop

Which is right. Also

cat /usr/share/applications/mimeinfo.cache | grep  x-directory/gnome-default-handler
x-directory/gnome-default-handler=kde4-dolphin.desktop;

Seems to be right too. What am I missing?

  • Admittedly, I'm not sure about this at all, but does X need to be restarted before those changes take effect? – HalosGhost Jul 28 '14 at 7:04
  • @HalosGhost I have not restarted X. Just firefox, I will double check on this one. – vfbsilva Jul 28 '14 at 14:22
  • Just restarted X no change at all. – vfbsilva Jul 29 '14 at 1:51
  • Which file chooser are you referring to? The one you see when using File -> Open or when you're trying to save a file? I don't think you can change that, that's the file chooser dialog provided by Gtk. – Wieland Jul 29 '14 at 9:41
  • @Wieland the one from file open... – vfbsilva Jul 29 '14 at 13:15
0

Type about:config in the address bar

Search for ui.allow_platform_file_picker

Toggle it to true

Restart Firefox.

  • 1
    I've checked that this is set to true but options remain the same. – Alfabravo Feb 2 '17 at 16:43
  • 7
    This solution no longer works in Firefox 53. – ecc Apr 15 '17 at 10:59
3

Currently (2018-09-25) there exists no user-configurable way to change this behaviour in Firefox.

This is a known bug: Firefox does not use default file manager

It was first reported on Bugzilla on 2016-07-08. At the time of writing this bug is unassigned and unresolved.

1

I'd have a similar problem running Manjaro 4.18.9-1. After install nautilus for a test, firefox started to open folders with nautilus, I removed nautilus and firefox then opened folders with Atom.

At least for me, this solution worked:

  • Close firefox
  • Go to your file manager (Thunar in my case), right click on a folder and click on "open as"
  • Mark "use this app as default" and choose your file manager
  • Open firefox and see if it worked
1

Firefox use GIO's GAppInfo. GIO's behaviour is slightly different from xdg-mime's. By adding inode/directory=ranger.desktop in $HOME/.config/mimeapps.list, my firefox can open directory properly.

You can check the diffents between xdg-mime query default inode/directory and gio mime inode/directory.

  • This is what I wanted. Great first post! – Wyatt8740 Jun 18 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.