1

I'm try for the second time use Arch Linux.

In this installation I get:

  • openbox
  • tint2
  • compton
  • catalyst-hook (Vi0L0's)

After starting the compton, I can not see what I'm typing in the terminal, videos (flash/html) freeze in fullscreen, teamviewer stops working and resize any window is extremely slow.

If I kill compton, everything it's work BUT resize keep slow.

How can I fix that?

~/config/compton.conf

backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
refresh-rate = "60";
vsync="none"

# Shadow
shadow = false;
no-dock-shadow = true;     # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true;  # Don't draw shadows on DND windows.
shadow-exclude = [ "n:w:*Firefox*" ]; # Not sure what it does or if it works

# Fading
fading = false;
no-fading-openclose = true

/etc/X11/xorg.conf

Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

~/.config/openbox/autostart.sh

tint2 &
sh ~/.fehbg &
conky -c ~/.conky/conkyrc_grey &
compton --backend glx --paint-on-overlay --glx-no-stencil --vsync opengl-swc --shadow-e
xclude "! name~=''" --config ~/.config/compton.conf -b &
pulseaudio --start &

~/.xinitrc

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
exec openbox-session
1

I have an ATI Radeon HD 6310.

This are the compton.conf settings I use:

backend = "glx";
paint-on-overlay = false;
glx-no-stencil = true;
refresh-rate = 0;
vsync = "opengl-mswc";

They work very well. Maybe they help you too?

  • Thanks for you answer my friend, but I leave the arch linux for a while and buy a macbook pro. Anyway, thanks! – Patrick Maciel Feb 3 '15 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.