9

Many people have talked about this issue but I've not found a satisfactory answer.

I'm on a debian jessie. Currently I have tried nvidia-driver as the driver but it caused the system to crash; so I have purged all the nvidia packages. But the problem is that /etc/X11/xorg.conf has been replaced with NVidia settings and the backup xorg.conf.backup has been removed.

The related configuration set by NVidia is:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

I once tried changing nvidia to intel(also NVidia -> Intel) but the resolution is much lower(my laptop has a Intel Corporation Haswell-ULT Integrated Graphics Controller as listed by lspci). So I might need to use nouveau as the driver; however simply changing nvidia to nouveau doesn't work.

It seems that the recent X system can be booted without xorg.conf(by rm /etc/X11/xorg.conf) but slower. So I still prefer the xorg.conf with my current settings.

The version of Xorg:

X.Org X Server 1.16.0
Release Date: 2014-07-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.14-1-amd64 x86_64 Debian
Current Operating System: Linux debian 3.14-1-amd64 #1 SMP Debian 3.14.9-1 (2014-06-30) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.14-1-amd64 root=UUID=e9341749-9dee-4cc9-878e-3b59ed1906b2 ro quiet
Build Date: 17 July 2014  10:22:36PM
xorg-server 2:1.16.0-1 (http://www.debian.org/support)
Current version of pixman: 0.32.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.

So are there any ways to re-generate the configuration file?

5

Xorg --configure while X is not running did it for me - I'm on debian Sid (unstable).

You MUST NOT have X running when you do this, and must be in a console TTY. (ctrl-alt-f1/f2/f3/f4/f5/f6)

If Xorg.conf doesn't change after doing this, and the program didn't return an error but printed an Xorg.conf configuration file to the screen, do Xorg --configure > /etc/xorg.conf to pipe the output into the file.

BUT the way that I got the official nvidia drivers working in the end was to uninstall the package manager's version and download the setup program from Nvidia's site. It's been working flawlessly since. The one time it didn't work (when I was trying to run minecraft), I set the variable LD_PRELOAD=/usr/lib/libGL.so.1 and it ran - lwjgl has problems detecting the correct libGL version to use.

| improve this answer | |
  • 2
    Thanks, I think that's the problem: I've always trying Xorg -configure after X has been started; I'll try when I come back to the laptop. BTW, nvidia-detect(from debian package) even reports there is no Nvidia graphics card available for the laptop, so will the official driver work? Do you have a similar issue about this? – Hongxu Chen Jul 28 '14 at 2:56
  • I did not have this particular problem, my installation detected my card just fine. What chipset do you have? (By the way, it's --configure with two - characters, and the way I stopped X was by stopping my DM service, lightdm in my case.) – Wyatt8740 Jul 28 '14 at 20:29
  • 2
    It seems that Xorg -configure is for my Xorg (both X.Org X Server 1.16.0 and 1.15.1). I tried downloading nvidia driver from the official site but still failed to use the driver when updating xorg.conf with nvidia-xconfig(blackscreen). And strangely I find that nvidia related module is NOT listed with lsmod. As to the answer itself, I suppose I should mark it as correct since it does answer my question(however, there is a blackscreen for that configuration). – Hongxu Chen Jul 29 '14 at 10:59
  • 1
    Thanks :) I hope you can figure out your problem - my laptop has integrated graphics, but I had that problem on it (the blackscreen). passing the argument nomodeset to the kernel at boot got it to work just enough that I could boot to a TTY and compile a new kernel. the new kernel I built worked. – Wyatt8740 Jul 30 '14 at 22:27
  • 1
    Sorry for replying late. It still doesn't work. I remove the quiet option during grub booting and the logging message does say that "gnome display manager"(I also tried lightdm, similar) has started and there is NO Failed according to it; but tty7 remains black screen with splashing cursor. When I force to startx in tty, it reports that there is no screen found; The xorg.conf generated by nvidia-xconfig contains the screen info but with NO name or its vendor name, does that matter? – Hongxu Chen Aug 5 '14 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.