4

I recently replaced my broken Sennheiser PC350 to a Beyerdynamic DT770 Pro 80 Ohm headphones and I've encountered a really annoying issue. Everything is too low. I can listen to it, but it's almost as if I'm on 10% of max volume. On Windows this issue isn't present at all, and is almost a little too loud on 100%.

Pulseaudio settings are set to 100%, and every slider in the alsamixer are set to 100% too. If I set the volume to 150%, the sound gets too saturated and distorted.

My sound chip is the Realtek ALC1150. I'm running Arch.

Edit

After thinking it was solved, the issue came back but I believe I have more of an understanding of the issue now. Using the line out port, green one, works from time to time, but more often than not, using any of the other ports will output the what you'd expect from line out. In a way, the issue is resolved since if I use any other ports than the line out, the sound is working like it should. I'd rather not though as Windows doesn't output anything at all when not using line out, and there are times where linux too won't output to anything but line out.

How come linux gets so confused? It's almost as if it believes the line out port is all of the other ports except for line out.

  • This is not really useful, but Realtek cards are terrible. Is this one of those integrated onto the motherboard deals? You might find a proper sound card would make for a better experience, assuming you can find one where you are. – Faheem Mitha Jul 26 '14 at 21:28
  • I haven't had any negative experiences with the onboard chip (until now), so I'd rather not shell out for a dedicated sound card to fix something that could possibly be easy to fix. – Raghap Jul 26 '14 at 22:15
  • It shouldn't be that big (10% vs 100%) of a difference. There is a 12 dB difference in the characteristic level (108 vs 96) and a 47% reduction in the impedance (150 vs 80). This should give you less than a 20 dB difference in level or about a 1/4 of the total loudness. – StrongBad Jul 27 '14 at 7:12
3

If it really works fine in windows, and you don't just have VLC's volume set past 100%, then you could possibly try installing pavucontrol if you use pulseaudio and check if the levels are maxed in there.

my sound card is an Audigy 2, so I can't help much with realtek, but try entering alsamixer and checking that center,pcm, pcm center, pcm front, etc are all at 100%.

if alsamixer doesn't show your chipset, hit f6 and see if it displays it as an option there.

As a last resort, as an electrical engineer, I would build an external amplifier with two lm386 IC's, which can be made for around $30 in parts at radio shack prices, and at digi-key prices, possibly $10 or less.

You might not want to do that, but a pre-made 'pre-amp' between your PC and your headphones might get the job done for around $50. I'm really suprised if this isn't a problem in windows - but I wish you good luck~!

PS Your 150 ohm speakers should be quieter than your beyerdynamics, if they really are 80 ohm. I've never seen such high values though, my headphones (32 ohm boses I got free from a friend) and my speakers (8 ohm 1978 jensen's) are both more typical.

  • I've tried most of what you wrote here, but thanks anyway! I really wish I could come with an answer or accept an answer here, but something really weird happened this morning when I booted the computer back up. It was working for whatever reason. The volume was too loud on 100%, like you'd expect as it's the max volume but with no distortion at all. I've set it down to 50% now, and it's still louder than the "old" 100%. I tried lowering it down to 10% and it really did sound like that with the old 100%. Eitherway, the issue is resolved but I don't know how. – Raghap Jul 28 '14 at 2:46
  • Good to hear - whatever you did must not have asserted itself until you rebooted, or something. – Wyatt8740 Jul 28 '14 at 20:28
1

If you're on a currently-supported GNU/Linux distribution and are keeping up-to-date with its package updates, and if you have Firefox installed and sound works in the browser, then you have a working PulseAudio setup on top of your ALSA. (We know that because Firefox 52+ is PulseAudio-only and package managers account for this. If you're still on Firefox 48 or something then try telling the package manager to upgrade it: this should result in a PulseAudio setup if you didn't already have one.)

PulseAudio's pavucontrol (install the package if it's not there) can set the volume to more than 100%, both overall (in the Output Devices tab) and per-application (in the Playback tab) which is particularly useful for overly-quiet video players etc. This can't normally be done in alsamixer et al (at least not without a ridiculous amount of .asoundrc programming), so that's a good reason to use PulseAudio instead.

One slight annoyance you then get is: if your desktop environment is showing an ALSA-based volume control on the taskbar, then any attempt to touch this volume control will likely override the work you did in pavucontrol, which is not so good if the user sitting at the keyboard doesn't know how to get back to pavucontrol. I worked around this for a friend by deleting the volume control from her LXDE panel and adding pavucontrol to the LXDE application launcher instead. All I had to tell her was the volume control is now at bottom left instead of bottom right because I've switched you to different sound software; she was fine with that.

1

Run hdajackretask GUI tool (alsa-tools-gui package in Ubuntu). Find your port, tick Override and choose Headphone, apply.

Surprisingly I got my volume back. Finally. Yay! (I'm using headphones). Sadly almost nobody recommends to try this tool.

0

It is not the soundcard.

Many of the larger headphones require more power than the dippy little built-in "power" amp can provide. This means you need a headphone amplifier. You can get an utterly competent one for about US$60. If you find yourself wanting to buy a US$600 tube amp, get the $100 amp and send me the excess cash, you'll never know the difference.

  • I was suspecting something like this, but as far as I know the Sennheiser PC350 are at 150 Ohms while these are at 80 Ohms, how come the PC350 output a much louder volume without distortion if they were higher in the Ohms? – Raghap Jul 27 '14 at 10:21
  • I don't know the answer. I do know that manufacturers play pretty fast and loose with their printed specifications and speaker resistance, everything else being equal, should work in direct proportionality to current and voltage. But other things aren't equal and sound equipment manufacturers either a) like to hide these difference or b) don't know how to conveniently characterize these differences or c) like to play the marketing game of a bigger/smaller number is better/worse than another number. – msw Jul 27 '14 at 15:09
0

I had this same issue on a Sony VAIO running CentOS 7.1 Alsamixer was not the limiting factor. In Settings --> Sound, there is an Output Volume slider across the top. The slider was at a marker labeled "Unamplified 100%", but allows sliding further to the right, supposedly into amplified territory, and this fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.