2

Already installed VMware Workstation 9 on my Linux CentOS 6.5 Final with 3.10.40-1.el6.elrepo.x86_64 running kernel. When I open VMware Workstation, it asks me to locate the Kernel Headers 3.10.40-1.el6.elrepo.x86_64.

THESE MESSAGE: I get on the internet, my kernel version is different of that message says. Outside, it is all the same.

message

I've tried to download the ELRepo Headers (lt-kernel-headers-3.10.40-1.el6.elrepo.x86_64.rpm), unzip and put in the way of VMware, however it does not recognize. Apparently I must be doing something wrong. What do I actually download, install and which path should point to the VMware Kernel C Header configuration to work?

The official page of the ELRepo, he talks to use the original Kernel conferring with glibc, however, already tried using the original kernel as a way to configure the VMware Kernel Headers C and does not work because the name of the kernels do not match indeed.

I wonder what it is the Kernel Header?

  • I think kernel-devel package will solve this issue. Just a guess, never tried out VMWare products. – beginer Jul 26 '14 at 7:57
  • Tnx for ur help. But then I just downloaded and what path I should use after unzip it? – Thufir Hawat Jul 26 '14 at 16:28
  • I dont think you need to download the zip or tar file. Did you try with yum? I mean like this: yum install kernel-devel – beginer Jul 26 '14 at 17:18
  • tnx beginer, ur comment helped me. – Thufir Hawat Jul 28 '14 at 15:13
2

SOLVED.

1-Downloaded the

kernel-lt-devel-3.10.40-1.el6.elrepo.x86_64.rpm 

from http://ftp.nluug.nl/os/Linux/distr/elrepo/archive/kernel/el6/x86_64/RPMS/

2-Installed (just executing the file)

3-Pointed de VMware configuration to

/usr/src/kernels/2.6.32-431.20.3.el6.x86_64/include/linux/

When the VMware start, another error appeared. Said that just cant load the module vmci of vmware.

4-So, compile the vmci module:

vmware-modconfig --console --build-mod vmci

5-install the module:

vmware-modconfig --console --install-pbm vmci

OR

vmware-modconfig --console --install-all

next, I tested:

modprobe vmci

SUCCESS

Just fine with my vmware running.

0

try

sudo yum install kernel-devel-3.10.40-1.el6.elrepo.x86_64

then run the VMware setup again

-2

Follow the steps below:

uname -a

then use your version number you get from uname -a to install the correct kernel-devel i.e.

yum install kernel-devel-3.10.0-514.2.2.el7.x86_64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.