4

From time to time my Gnome 3 shell or some parts of it are crashing. Gnome sees a time out and is forcing the user to logout without other possibilities.

"Oh no! Something has gone wrong." See superuser for a screenshot. (Fail whale is providing this dialog.)

Is there a way to stop gnome from doing that? Since the other programs are still running and working fine... In my case its clearly a timeout, since a scientific analysis eats up all memory and after its done Gnome has a hard time to recover.

(I experienced also these crashes, when I was using some (combination of) extensions which are buggy. In that case the probably only or best solution is to not use those extensions... also considering the posts I've read about this.)

4
  • Did you consider switching to another desktop environment, e.g. KDE or, even better, XFCE (this one is better because you're short on memory, and XFCE is a lightweight DE). Or do you require the solution preserving GNOME?
    – Ruslan
    Aug 13 '14 at 11:34
  • 1
    @Ruslan: Oh, I have used KDE for a long time and during 1 week of Gnome 3 usage, I was convinced that Gnome is a lot better :) I have 4 GB of memory and this is enough for 98% of the time.
    – PythoNic
    Aug 13 '14 at 11:39
  • 4
    This link says you can just Alt+F4 that "Log Out" window.
    – Ruslan
    Aug 13 '14 at 11:49
  • @Ruslan: try'd ALT+F4 after a extension overload crash and it doesn't work. Via the given kill command, it works. If I choose to kill gnome-session twice, it doesnt work. I'll try out gnome-shell --replace
    – PythoNic
    Aug 13 '14 at 17:28
1

Thanks to Ruslan's comment (upvote!) and some testing I probably found a solution for the next real case:

  1. Try ALT+F4, or clicking somewhere on the "fail whale" message (to get the focus) and then ALT+F4
  2. If 1 doesnt work: go to a tty and type DISPLAY=:0 gnome-shell --replace and then go back to Gnome and try ALT+F4 again. It should work now.

Some background:

There are 2 cases. If gnome-session has crashed, ALT+F4 won't work (since it provides the window frames and all of its functions). If gnome-settings-daemon has crashed, then ALT+F4 still works, but your windows might look a bit different.

4
  • I'd also suggest to play with RequiredComponents in gnome.session shown in that link — maybe make some of them not required or whatever.
    – Ruslan
    Aug 13 '14 at 18:46
  • If I worked it out right, then the part which causes my problem is essential: gnome-shell. In the other cases ALT+F4 should be enough.
    – PythoNic
    Aug 16 '14 at 4:29
  • Just for completeness: I didn't experience this bug since upgrade to Debian Jessie / Gnome 3.12
    – PythoNic
    Sep 16 '14 at 20:42
  • 1
    Now in 3.16, if you alt-f4 after restarting gnome-shell from tty it will logout you even if gnome-shell is now fine, just like if you clicked on the "Log out" button.
    – p91paul
    Jun 27 '15 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.