2

I run as root pacman -Syu
However it just skips right over [core], without prompts, etc.
Just like it was normal to proceed when 0% done.

It just proceeds with extra and community.
How can I force the db to be updated or preferably fix this behaviour?

  • 2
    post the log, please. – strugee Jul 24 '14 at 5:29
  • You should probably start in /etc/pacman.conf – mikeserv Jul 24 '14 at 6:21
  • @mikeserv as I said in my answer, this is probably more indicative of a corrupted DB than a configuration problem. good idea, though. – strugee Jul 24 '14 at 6:52
  • @strugee - I accept that you're likely right. but if it was a misplaced comment or something in there it sure would be easier to fix. So that's where I'd start. – mikeserv Jul 24 '14 at 7:50
  • 1
    @mikeserv no, in that case it would just not print a line for core at all. – strugee Jul 26 '14 at 6:45
3

Your question was a little lacking in details, so I can only answer part of your question. When you post the logs from your terminal, I can answer the rest.

How can I force the db to be updated?

Passing the -yy switch to pacman forces it to refresh the DBs from the internet, even if they're not out of date. Use e.g. pacman -Syyu to update your system with fresh DBs.

In subsequent comments, you've stated that pacman just printed 0%, with a progress bar, and continued on its merry way. This probably means you have a corrupted DB on the local disk. In that case, just do a pacman run using -yy and you should be fine.

  • that fixed it, thanks! Any ideas why it might not have worked? – Mark Jul 24 '14 at 5:33
  • @Mark to be honest, since you didn't post your logs, I'm not entirely sure what went wrong in the first place. do you mean it just said [core] is up to date or somesuch, or did it just print [core] [ ] 0% and move on? – strugee Jul 24 '14 at 5:35
  • second version. Maybe I skipped something in setting it up. Doesn't matter aynways now. – Mark Jul 24 '14 at 6:25
  • @Mark I've updated the answer. my guess is that you had a corrupt DB, but as you said, it doesn't matter. glad I could help. – strugee Jul 24 '14 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.