1

I have a BTRFS RAID5 setup (no mdadm) with four disks (the fifth failed). Now I am trying to recover the files but as soon as I try to rsync the files over to another disk, the system hangs after copying the first file. The strange thing is the "sending file list" works as expected but then it locks up. I'm using Antergos (Arch Linux) with the most recent stable kernel.

I also tried to rebuild the array: instant lockup. Tried to remove the missing device and rebuild: same result.

Is there any way to recover the data?

  • If there is a kernel panic involved in those lockups you should post it along with your question. Otherwise I'd update kernel and/or put all disks in another box just in case it's the hardware... if it still locks up (and silently at that) you should probably talk to the btrfs devs... – frostschutz Jul 23 '14 at 13:31
  • I tried two different PCs and the 3.12 LTS kernel, usually it just locks up silently. At most there are some messages about bad checksums before the lockup, but it looks like i should ask on the btrfs ML. Thanks though :) – icefex Jul 23 '14 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.