7

I am trying to configure multiple postfix-2.12 instances on FreeBSD 10.0-RELEASE following the README.

postmulti -e init
postmulti -I postfix-out -G mta -e create
...

This all works I can start and stop instances everything seems good. When I test sending an email locally using telnet. Postfix logs the following fatal: unknown service: smtp/tcp error.

The configuration files are vanilla no chroot in master.cf.

 mynetworks = 127.0.0.1/8 192.168.5.0/24

If I run postfix as a single instance everything works fine. So postfix can read /etc/services when run as a single instance.

The spool directory that is created with postmulti looks identical to postfix spool dir.

I have been hammering at this for way too long. Has anyone implemented multiple instances of postfix on FreeBSD or can give some suggestions?

2

For the best quality answers, you will need to post the content of master.cf and more details about your configuration. But, looking at my configuration for example:

==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd

Here we see that the smtp listener runs in a chroot environment. There should be a usable copy of /etc/services in that chroot directory:

$ grep '^smtp' $(sudo postconf -h queue_directory)/etc/services
smtp        25/tcp      mail

If there is an etc/services file under the queue directory but it has the wrong content, or the file is not there, re-check the postfix installation instructions to make sure they were carried out correctly.

  • I had a similar issue and fixed it by copying both /etc/resolv.conf and /etc/services into the chrooted postfix queue directory. – Phssthpok Nov 7 '14 at 6:43
  • @Phssthpok same for me! I'd like to know why serverfault.com/questions/661621/… – Anentropic Jan 22 '15 at 18:18
0

I have the same problem. I made a second instance of postfix and my second-instance-master.cf is

#smtp      inet  n       -       -       -       -       smtpd
ip.second.eth.card:smtp  inet  n       -       -       -       -       smtpd
  • 1
    Do you still have the same problem although you made a second instance? Or did you have the same problem and did the extra line solve this? – Anthon Jun 21 '15 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.