1

I bought a cheap Aztech WL572USB Wireless-N USB Adapter.

It clearly says it supports linux on the documentation but strangely doesn't even provide any way to set it up. I assumed it's plug-n-play but it didn't work, neither on my physical machine (I turned built-in wireless card off using Fn+F2) nor on the intended Kali Linux Virtual Machine, the VMware says: "Connect Ralink Wireless Adapter" and when I do, I still can't see a wireless interface on ifconfig or iwconfig. how can I get this to work?

Here's an Aztech doc with two important information: LINK

It says it supports Linux, and it says it uses the Chipset: Ralink RT5370

Notes:

  • Physical PC OS: Linux Mint Debian Edition.

  • Virtual Machine OS: Kali Linux (target device).

  • Virtualization: VMware.

  • 1
    Here are instructions from Debian for setting it up on the host machine: wiki.debian.org/rt2800usb – derobert Jul 23 '14 at 0:38
  • Have you loaded the firmware/driver? – jasonwryan Jul 23 '14 at 0:38
  • How do I do that? – Mars Jul 23 '14 at 1:32
  • @derobert I followed the instructions in the link, still nothing on ifconfig or iwconfig or the Network Manager GUI. – Mars Jul 23 '14 at 1:34
  • Is the module loaded? – jasonwryan Jul 23 '14 at 1:43
3

Grepping the drivers directory of the kernel source tree for RT5370 turns up;

./net/wireless/rt2x00/Kconfig:         Supported chips: RT5370

Kconfig files are used to provide information for things like make menuconfig when configuring a kernel; this one happens to contain information for a number of Ralink PCI and USB based chipsets. From the same entry:

This adds support for rt53xx wireless chipset family to the rt2800usb driver.

Try lsmod | grep rt2800. If something turns up, the driver is loaded, skip to the next paragraph. If not, try sudo modprobe rt2800usb. If that fails, you need to follow the guide derobert pointed out.

To verify the interface is there, use ip link or ifconfig -a.

  • Tried lsmod | grep rt2800 and it didn't show anything, did sudo modprobe rt2800usb then lsmod | grep rt2800 and it showed: lsmod | grep rt2800 rt2800usb 21813 0 rt2x00usb 17426 1 rt2800usb rt2800lib 72679 1 rt2800usb rt2x00lib 41387 3 rt2x00usb,rt2800lib,rt2800usb mac80211 427800 3 rt2x00lib,rt2x00usb,rt2800lib crc_ccitt 12331 1 rt2800lib usbcore 142158 7 uhci_hcd,rt2x00usb,rt2800usb,ehci_hcd,ehci_pci,usbhid – Mars Jul 23 '14 at 17:49
  • ^ How do I do line breaks in replies? <br/> doesn't work. – Mars Jul 23 '14 at 17:51
  • I plugged the device on the Guest OS after that, and it still didn't work. And ip link or ifconfig -a don't either show wlan0, only eth0 and lo. – Mars Jul 23 '14 at 17:53
  • The driver is loaded, so presumably the interface also exists (the reason I said to use ifconfig -a is that just plain ifconfig only shows interfaces that are "up", and this one may be "down"). If you can confirm that, then you most likely have a working interface, you just have to configure it in order to connect to a WLAN (but that's a separate question). WRT line breaks in comments, I've never seen any, I'd presume you can't. – goldilocks Jul 23 '14 at 17:57
  • I also installed wicd yesterday after following the guide on Debian wiki, still doesn't show any wireless extension. Thanks for your time, I guess I'll try returning the device and buy something that works as plug n play on linux. – Mars Jul 23 '14 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.