I have set up a VM of Ubuntu server, have installed OpenSSH, and am now trying to connect to it using Putty. Within Putty, under "Host name", I put "Ubuntu", given this is what I thought it was called when I set up the VM. However, I just get the error: "Connection Timed Out".

I also tried putting "127.0.0.1" into the host name within Putty and just get "Connection Refused". Note that I have done the port forwarding for SSH and HTTP within Oracle VM, so I am at a loss as to how to get it running.

  • FWIW bridged/host only didn't work for me, but I was able to work around it by, in essence, only SSH'ing "out" (scp can go both ways, after all) so I didn't need SSH access within the guest. – rogerdpack Dec 6 '16 at 21:09
up vote 145 down vote accepted

VirtualBox will create a private network (10.0.2.x) which will be connected to your host network using NAT. (Unless configured otherwise.)

This means that you cannot directly access any host of the private network from the host network. To do so, you need some port forwarding. In the network preferences of your VM you can, for example, configure VirtualBox to open port 22 on 127.0.1.1 (a loopback address of your host) and forward any traffic to port 22 of 10.0.2.1 (the internal address of your VM)

This way, you can point putty to Port 22 of 127.0.1.1 and VirtualBox will redirect this connection to your VM where its ssh daemon will answer it, allowing you to log in.

  • 16
    Thanks, this worked for me. From cygwin I can now ssh username@127.0.1.1 and I'm in. The panel you need is Settings->Network->Port Forwarding, and mine now looks as shown at: imgur.com/BjGh3N2 – user7543 May 1 '15 at 15:26
  • 31
    This will NOT work if you already have ssh running on your host because the ports overlap. Redirect port 127.0.1.1:2222 to 10.0.2.X:22 and then run 'ssh 127.0.1.1 -p 2222' from your host' – dzlatkov May 29 '15 at 7:10
  • 7
    Also, make sure you have openssh-server installed on the client OS. sudo apt-get install openssh-server – Illuminati Sep 3 '16 at 13:29
  • 11
    Just had this issue myself - thanks for the explaination. I basically followed what you said. I went to Settings and my connection showed 'NAT'. I clicked the 'port forwarding' option at the bottom of the screen. I gave it a name 'PuTTY-port-fwd', protocol TCP, host IP 127.0.0.1 host port 2222 guest IP 10.0.2.15 guest port 22. I then launched PuTTY and set it to 127.0.0.1 port 2222 and it connected to my OpenSUSE vm. Thanks guys, hope this helps anyone in future ;-) – BubbleMonster Dec 3 '16 at 17:00
  • 3
    This worked for me, although I had to tell VirtualBox to open port 2222 on 127.0.0.1. Then I was able to log in using ssh -p 2222 user@127.0.0.1 – mchen.ja Jan 25 '17 at 15:24

I wanted to use putty to connect to my ubuntu on virtual box (comfort reasons, the VB is just weird. I can't work unless it is on a proper terminal). Anyway,

  1. Make sure ssh client is installed on your Linux. If not, install it sudo apt install ssh.
  2. Power off the OS.
  3. Now on your VB go to Settings -> Network -> on Adapter 1 choose Host-only adapter->click OK.
  4. Now start your OS. Run ifconfig; now the inet address is your IP.
  5. Use this and run it on your putty. Login with your credentials.

The only disadvantage of using host-only adapter is that your guest OS won't have access to the wider network (eg the Internet).

If you also need your VM to have internet access, leave Adapter 1 as NAT and enable Adapter 2, configured as a Host-Only adapter. This will allow your VM to connect to the internet using NAT as well as make a local connection to your Host using Host-Only.

  • works like a charm, thanks! – tigerjack89 May 20 '16 at 15:51
  • 2
    "bridged" will put the ip on your local interface and bridge access to the greater internet – Duke Oct 11 '16 at 2:37
  • 2
    The advantage of using two interfaces, as described here, over bridged, is that you don't rely on the local dhcp server accepting your requests. Most dhcp servers in public places (ariport, airplanes, hotels, and even most company networks) won't offer a second ip through the same wifi adapter, so a bridged VM will not work in those environment. Here's a really good step-by-step on how to set this particular config up: christophermaier.name/2010/09/01/… – Yves Dorfsman Jun 30 '17 at 13:37

First you need to decide if your VM connected to your host machine via a bridge connection or via a NAT, but ether way you'll need to put the VM IP address in putty to be able to connect to ip, in the VM terminal run this command to show you the machine IP address (and no 127.0.0.1 is not the machine IP address)

VM # ip addr show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:d9:16:b3 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.1 scope global eth0
       valid_lft forever preferred_lft forever

in this case my IP address will by 10.0.2.15,

First try to make sure you can communicate on a basic level with VM, open a terminal window on your host, and try to ping the VM

HOST # ping 10.0.2.15

PING 10.0.2.15 (10.0.2.15) 56(84) bytes of data.
64 bytes from 10.0.2.15: icmp_seq=1 ttl=64 time=0.045 ms
64 bytes from 10.0.2.15: icmp_seq=2 ttl=64 time=0.110 ms
64 bytes from 10.0.2.15: icmp_seq=3 ttl=64 time=0.099 ms

If you get ant result, then make sure you have a ssh service running on the VM, in the terminal on your VM type as root,

VM # netstat -lnpt | grep 22
tcp   0  0  0.0.0.0:22  0.0.0.0:*  LISTEN  2361/sshd

This tell as we have a service/process with PID(2361) called sshd (OpenSSH daemon) listening to port 22.

You can test if the service work correctly by trying to ssh to it from the VM it self,

VM # ssh 127.0.0.1

Next you neet to make sure that you are not blocking port 22 in your firewall/iptables, I can not believe so, but check it out anyway. In the VM type this command to show you the iptables,

VM # iptables -nvL INPUT

in the output you should have line like this one:

0  0  ACCEPT  tcp  --  *  *  0.0.0.0/0  0.0.0.0/0  tcp  dpt:22  ctstate  NEW
  • Tried that, and apparently my ip address is 10.0.2.15. I tried entering that into Putty and just got the connection timed out error again. I also tried the nvL command you mention, and get a load of (for lack of a better word) stuff - Chain INPUT (policy accept......, chain FORWARD..... etc – wickywills Jul 22 '14 at 21:03
  • I rewrite my answer with few more points you can check, please let me know. – Rabin Jul 23 '14 at 6:37
  • 1
    What if ping 10.0.2.15 times out? I use NAT. – Dan Dascalescu Dec 1 '14 at 11:20
  • Port forwarding was the answer. – Dan Dascalescu Dec 1 '14 at 11:25

My resolution was similar to Roman T's however I needed to add a few extra steps. In my case I had Ubuntu Server 14 VM running on a Windows 8 Desktop in Windows 2008 domain. If I tried NAT or Bridge I could access the Internet but couldn't connect via SSH.

If I tried Host Only Adapter then that would allow me to SSH to machine but couldn't access the Internet.

I tried Port forwarding as well and no joy. Opened up Wireshark and it just wasn't finding VM.

So my solution was to add a second network adapter.

Method

With VM powered down

  1. Click Settings > Network Click Adapter 1 and choose Bridged Adapter
  2. Click Adapter 2 and choose Host Only Adapter
  3. Click File > Preferences > Networks Under NAT Networks if you don't see a NAT Network click on + icon to add NAT Network.
  4. Click Host-Only Networks if you don't see a host only network click + icon to add one

Start up VM

  1. In order to see network adapter you need to type

    ifconfig -a
    
  2. You may see the network adapter is added with a mac address but not an IP?

  3. If so then you need to edit /etc/network/interfaces in order to configure DHCP. Example below using VI/VIM but you can use editor of your choice

    sudo vi /etc/network/interfaces
    
  4. add the lines

    auto eth1
    iface eth1 inet dhcp
    
  5. save and exit file.
  6. Then try restarting network service using below command

    sudo service networking restart
    
  7. Or if that fails then restart VM.
  8. Once restarted type below to see if you eth1 has been allocated an IP address

    ifconfig -a
    
  9. if so then see if you can SSH on to the VM
  • I had tried your solution, but no IP has been assigned to new interface. What is more I have DHCP enabled in my VBox. – Athlan Feb 21 '16 at 22:21
  • this worked for me, thanks! – Kenny Cason Nov 14 '16 at 22:35

The following instructions worked with Ubuntu 14.04 and Oracle VirtualBox 4.3.30.

Do this in VirtualBox:

  1. Right-click your virtual machine, select "Settings", and then select "Network".

  2. Next to "Attached to", select "Host-only Adapter". As a side note, "Bridged Adapter" will also work, check the VirtualBox documentation for more details about each option.

Do this inside your Virtual Machine:

  1. Find your network IP address by opening a terminal and typing ifconfig. Observe the IP address displayed next to eth0, under "inet addr". You can also see your IP address if you click the Network icon in the upper-right corner of your desktop, and then select "Connection Information".

  2. Install openssh-server by typing the following at the terminal:

    sudo apt-get install openssh-server
    
  3. Just in case, restart the virtual machine.

Now you can connect from PuTTY using the IP address from step 1 above and port 22.

protected by Community May 16 '16 at 8:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.