I have set up a VM of Ubuntu server, have installed OpenSSH, and am now trying to connect to it using Putty. Within Putty, under "Host name", I put "Ubuntu", given this is what I thought it was called when I set up the VM. However, I just get the error: "Connection Timed Out".

I also tried putting "" into the host name within Putty and just get "Connection Refused". Note that I have done the port forwarding for SSH and HTTP within Oracle VM, so I am at a loss as to how to get it running.

  • 1
    FWIW bridged/host only didn't work for me, but I was able to work around it by, in essence, only SSH'ing "out" (scp can go both ways, after all) so I didn't need SSH access within the guest.
    – rogerdpack
    Commented Dec 6, 2016 at 21:09

6 Answers 6


VirtualBox will create a private network (10.0.2.x) which will be connected to your host network using NAT. (Unless configured otherwise.)

This means that you cannot directly access any host of the private network from the host network. To do so, you need some port forwarding. In the network preferences of your VM you can, for example, configure VirtualBox to open port 22 on (a loopback address of your host) and forward any traffic to port 22 of (the internal address of your VM)

This way, you can point putty to Port 22 of and VirtualBox will redirect this connection to your VM where its ssh daemon will answer it, allowing you to log in.

  • 25
    Thanks, this worked for me. From cygwin I can now ssh [email protected] and I'm in. The panel you need is Settings->Network->Port Forwarding, and mine now looks as shown at: imgur.com/BjGh3N2
    – user7543
    Commented May 1, 2015 at 15:26
  • 51
    This will NOT work if you already have ssh running on your host because the ports overlap. Redirect port to 10.0.2.X:22 and then run 'ssh -p 2222' from your host'
    – dzlatkov
    Commented May 29, 2015 at 7:10
  • 11
    Also, make sure you have openssh-server installed on the client OS. sudo apt-get install openssh-server
    – Illuminati
    Commented Sep 3, 2016 at 13:29
  • 19
    Just had this issue myself - thanks for the explaination. I basically followed what you said. I went to Settings and my connection showed 'NAT'. I clicked the 'port forwarding' option at the bottom of the screen. I gave it a name 'PuTTY-port-fwd', protocol TCP, host IP host port 2222 guest IP guest port 22. I then launched PuTTY and set it to port 2222 and it connected to my OpenSUSE vm. Thanks guys, hope this helps anyone in future ;-) Commented Dec 3, 2016 at 17:00
  • 4
    This worked for me, although I had to tell VirtualBox to open port 2222 on Then I was able to log in using ssh -p 2222 [email protected]
    – m81
    Commented Jan 25, 2017 at 15:24

I wanted to use putty to connect to my ubuntu on virtual box (comfort reasons, the VB is just weird. I can't work unless it is on a proper terminal). Anyway,

  1. Make sure ssh client is installed on your Linux. If not, install it sudo apt install ssh.
  2. Power off the OS.
  3. Now on your VB go to Settings -> Network -> on Adapter 1 choose Host-only adapter->click OK.
  4. Now start your OS. Run ifconfig; now the inet address is your IP.
  5. Use this and run it on your putty. Login with your credentials.

The only disadvantage of using host-only adapter is that your guest OS won't have access to the wider network (eg the Internet).

If you also need your VM to have internet access, leave Adapter 1 as NAT and enable Adapter 2, configured as a Host-Only adapter. This will allow your VM to connect to the internet using NAT as well as make a local connection to your Host using Host-Only.

  • 6
    "bridged" will put the ip on your local interface and bridge access to the greater internet
    – Duke
    Commented Oct 11, 2016 at 2:37
  • 3
    The advantage of using two interfaces, as described here, over bridged, is that you don't rely on the local dhcp server accepting your requests. Most dhcp servers in public places (ariport, airplanes, hotels, and even most company networks) won't offer a second ip through the same wifi adapter, so a bridged VM will not work in those environment. Here's a really good step-by-step on how to set this particular config up: christophermaier.name/2010/09/01/… Commented Jun 30, 2017 at 13:37
  • Work like a charm, but you should put Adapter 2 on the 3rd option so that people leave the NAT alone Commented Jan 13, 2019 at 5:20
  • thanks very much. but when I change the Ubuntu Network setting from NAT to host only adapter it can't connect to internet anymore, any solution?
    – Luke
    Commented May 15, 2019 at 11:23
  • This is perfect. Most of the answers I found suggests that the SSH client is installed in the guest machine. In my case it was not. Commented May 13, 2020 at 15:23

First you need to decide if your VM connected to your host machine via a bridge connection or via a NAT, but ether way you'll need to put the VM IP address in putty to be able to connect to ip, in the VM terminal run this command to show you the machine IP address (and no is not the machine IP address)

VM # ip addr show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:d9:16:b3 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
       valid_lft forever preferred_lft forever

in this case my IP address will by,

First try to make sure you can communicate on a basic level with VM, open a terminal window on your host, and try to ping the VM

HOST # ping

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.045 ms
64 bytes from icmp_seq=2 ttl=64 time=0.110 ms
64 bytes from icmp_seq=3 ttl=64 time=0.099 ms

If you get ant result, then make sure you have a ssh service running on the VM, in the terminal on your VM type as root,

VM # netstat -lnpt | grep 22
tcp   0  0*  LISTEN  2361/sshd

This tell as we have a service/process with PID(2361) called sshd (OpenSSH daemon) listening to port 22.

You can test if the service work correctly by trying to ssh to it from the VM it self,

VM # ssh

Next you neet to make sure that you are not blocking port 22 in your firewall/iptables, I can not believe so, but check it out anyway. In the VM type this command to show you the iptables,

VM # iptables -nvL INPUT

in the output you should have line like this one:

0  0  ACCEPT  tcp  --  *  *  tcp  dpt:22  ctstate  NEW
  • Tried that, and apparently my ip address is I tried entering that into Putty and just got the connection timed out error again. I also tried the nvL command you mention, and get a load of (for lack of a better word) stuff - Chain INPUT (policy accept......, chain FORWARD..... etc
    – wickywills
    Commented Jul 22, 2014 at 21:03
  • I rewrite my answer with few more points you can check, please let me know.
    – Rabin
    Commented Jul 23, 2014 at 6:37
  • 6
    What if ping times out? I use NAT. Commented Dec 1, 2014 at 11:20
  • Port forwarding was the answer. Commented Dec 1, 2014 at 11:25
  • For convenience: iptables -A INPUT -p tcp --dport ssh -j ACCEPT will allow incoming traffic if you don't see tcp in your iptables. Commented Apr 6, 2019 at 17:06

My resolution was similar to Roman T's however I needed to add a few extra steps. In my case I had Ubuntu Server 14 VM running on a Windows 8 Desktop in Windows 2008 domain. If I tried NAT or Bridge I could access the Internet but couldn't connect via SSH.

If I tried Host Only Adapter then that would allow me to SSH to machine but couldn't access the Internet.

I tried Port forwarding as well and no joy. Opened up Wireshark and it just wasn't finding VM.

So my solution was to add a second network adapter.


With VM powered down

  1. Click Settings > Network Click Adapter 1 and choose Bridged Adapter
  2. Click Adapter 2 and choose Host Only Adapter
  3. Click File > Preferences > Networks Under NAT Networks if you don't see a NAT Network click on + icon to add NAT Network.
  4. Click Host-Only Networks if you don't see a host only network click + icon to add one

Start up VM

  1. In order to see network adapter you need to type

    ifconfig -a
  2. You may see the network adapter is added with a mac address but not an IP?

  3. If so then you need to edit /etc/network/interfaces in order to configure DHCP. Example below using VI/VIM but you can use editor of your choice

    sudo vi /etc/network/interfaces
  4. add the lines

    auto eth1
    iface eth1 inet dhcp
  5. save and exit file.
  6. Then try restarting network service using below command

    sudo service networking restart
  7. Or if that fails then restart VM.
  8. Once restarted type below to see if you eth1 has been allocated an IP address

    ifconfig -a
  9. if so then see if you can SSH on to the VM
  • I had tried your solution, but no IP has been assigned to new interface. What is more I have DHCP enabled in my VBox.
    – Athlan
    Commented Feb 21, 2016 at 22:21

The following instructions worked with Ubuntu 14.04 and Oracle VirtualBox 4.3.30.

Do this in VirtualBox:

  1. Right-click your virtual machine, select "Settings", and then select "Network".

  2. Next to "Attached to", select "Host-only Adapter". As a side note, "Bridged Adapter" will also work, check the VirtualBox documentation for more details about each option.

Do this inside your Virtual Machine:

  1. Find your network IP address by opening a terminal and typing ifconfig. Observe the IP address displayed next to eth0, under "inet addr". You can also see your IP address if you click the Network icon in the upper-right corner of your desktop, and then select "Connection Information".

  2. Install openssh-server by typing the following at the terminal:

    sudo apt-get install openssh-server
  3. Just in case, restart the virtual machine.

Now you can connect from PuTTY using the IP address from step 1 above and port 22.


For Ubuntu 18.04 and VirtualBox 5.2:

  1. Create a Host Network Interface

    i. On Virtualbox, click File/Host Network Manager.

    ii. If you don't already have a Host Network adapter (default vboxnet0), click Create.

  2. Enable Host-only Adapter settings for VM

    i. On Virtualbox, right click on your VM and select Settings.

    ii. Click Network and select Adapter 2.

    iii. Click Enable Network Adapter.

    iv. Under Attached to: select Host-only Adapter. The name of the adapter you created in step 1 should appear (default vboxnet0).

  3. Configure network settings in VM

    i. Start your VM and check which interface was added: ip a. Look for the interface that doesn't have an inet address. On mine, it was enp0s8.

    ii. Edit /etc/netplan/01-netcfg.yaml. e.g. sudo vi /etc/netplan/01-netcfg.yaml.

    iii. Under the settings for the original adapter, add configuration details:

        addresses: []
        dhcp4: no

    This assigns a static ip address for your VM for SSH convenience. If you want dhcp to handle the addressing instead, leave out the address and gateway config and set dhcp4 to yes.

    iv. Reload the configuration file: sudo netplan apply.

  4. SSH into your VM

    i. If you have not installed ssh in the VM: sudo apt install ssh.

    ii. From your host machine, SSH into the VM: ssh <username>@

  • Thanks, helped me out. For anyone else who has a blank netplan config file, make sure to add the 'network' and 'ethernets' sections above 'enp0s8' (in this case)
    – chrismacp
    Commented Feb 12, 2021 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .