3

I've had the following issue across multiple music players and multiple distro's. Currently I am experiencing it in Rhythmbox on Arch Linux.

Whenever I play music and then pause a track I am unable to resume it, it simply seems to "stay paused". However when I manually skip ahead in a track it works just fine. Similarly my music seems to stop playing slightly before the end of a trakc and then just "stops", I have to manually skip to the next track.

My sound is coming through a port in my monitor, which receives the sound via the HDMI cable. However I've also tried the audio jack coming straight from the motherboard with the same results.

Any ideas why this might be happening?

Edit: additional info as requested:

rhythmbox -d log: http://pastebin.com/rueUaNMZ (relevant entries appear to start at line 2017, nothing of value that I can see though).

I opened Rhythmbox, pressed play, pressed pause, pressed play again (didn't work) then closed Rhythmbox.

Hardware info:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC888-VD Analog [ALC888-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC888-VD Digital [ALC888-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I've tried both ALC888-VD Analog and HDMI 0

It does nothing at all when I press play, nothing happens UI wise or audio wise. Long or short pause does not make any difference.

I am using pulseaudio-alsa (Arch Linux).

  • Can you give us the output of rhythmbox -d, which is running rhythmbox in debugging mode? – polym Jul 22 '14 at 17:47
  • When you say it seems to stay paused, do you mean the UI says it still paused? Or does the UI act as if it is playing, but there is no sound output? Also, does this happen only for long pauses, or short ones, or both? (E.g., if you pause it for a second, then immediately unpause, is it fine?). Finally, could you please add some sound setup details-what sound hardware, and are you using PulseAudio? – derobert Jul 22 '14 at 21:13
  • Thanks for your responses, I've added the requested info in my question above. – Naatan Jul 23 '14 at 15:40
  • @Naatan: I used to have those problems too. But using fully updated latest Fedora version seems to fix it. Have you tried Fedora 20? (Maybe you don't want to change distro, though) – Peque Aug 4 '14 at 11:36
  • Thanks @Peque, changing distro is not really an option I'm willing to consider. – Naatan Aug 4 '14 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.