1

I'm using Evolution with evolution-mapi to access an Exchange e-mail server.
It has worked flawlessly in the past, but recently it will fail to authenticate, asking my password endlessly. If I enter the correct password, it tells me that it is incorrect.
If I enter an incorrect password, it closes the prompt, but fails to obtain the mail from the inbox (due to the truly incorrect password).

I fixed part of the issue by pointing my client to the server's IP address rather than its hostname, but it will still occasionally fail to send/receive e-mail.

EDIT: What I can do:

I am able to ping the server via its hostname and IP address with no packet loss. Since this is an internal server (or at least I'm accessing it via LAN), I have no reason to use a FQDN.

I am able to use the server for its other functions, namely a network-mountable directory where we store shared files for work.

The server appears to be fully operable. I'm under the impression that this issue is specific to Evolution or the MAPI plugin, or at least the versions thereof available in Ubuntu 14.04.

EDIT 2: It seems to be on and off whether a certain session of Evolution will properly authenticate. Also, each time I enter my password, I am given the option to save the password to my keyring, but it never seems to actually save.

  • Can we assume that the Exchange server is being successfully used by others? – garethTheRed Jul 22 '14 at 14:16
  • The Exchange server serves as the mailserver for my office of 10-20 people. I'm the oddball that doesn't use Outlook, since I'm running Ubuntu. It runs fine for everyone else. – 2mac Jul 22 '14 at 14:24
  • I think you'll find that you're the sensible one - the others just haven't realised this yet :-) Have you recently changed your DNS settings in Network Manager? Can you ping the Exchange server by IP, hostname and FQDN? It might be worth editing the question will everything you've done so far to avoid too many question and answer comments here. – garethTheRed Jul 22 '14 at 14:29
0

I had this (or an eerily similar issue) using Evolution on Fedora 21 Xfce spin over IMAP. The general consensus seems to be that Evolution somehow stops being able to communicate with the system keyring.

The only thing that fixed it for me was this unlikely sequence of actions. It may not fix the issue permanently, but it has certainly done the trick for me, for now.

In case the link breaks, here's a copy-and-paste of the steps to to follow:

  • Exit evolution
  • Clear the entire directory of ~/.gnome2/keyrings/ (did not exist on my system)
  • run seahorse and verify that there are no passwords shown
  • Exit seahorse
  • completely remove seahorse (sudo yum remove seahorse)
  • restart the computer
  • run evolution after restart
  • enter passwords as normal
  • you will be asked to enter a password keyring
  • close evolution
  • install seahorse
  • you may have to restart again? (Can't remember where I did it)
  • run evolution, you will be asked for the passwords again and the keyring (I didn't get asked for the passwords again)

Evolution should keep the passwords now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.