2

UPDATE:

I posted on the Tiger VNC forum and someone suggested that this may be a result of PolicyKit (now called PolKit, I believe). Does anyone know how to change this policy?

These are all machines behind a firewall in a small startup. It would be much easier if I could get GUI admin rights when I use VNC to connect to the server.

--

I've installed (Tiger) VNC Server on a new Centos 7 install.

It seems to be working ok but when I use VNC to connect as user admin (created as ua system administrator) it does not get administrator rights.

For example, via VNC the admin user cannot change network settings but when logged in directly the same user can change network settings. Same for other administrator functions.

I suspect its something to do with the PAM security context or the runuser -l command that starts the server but I can't seem to find out what to change.

Any suggestions most appreciated.

FYI:

I setup the VNC Server these instructions from this blog post.

and from the directions at the top of the file:

/lib/systemd/system/vncserver@.service

and man systemctl page

1

This worked for me

vi /etc/security/access.conf

In the section:

# Disallow non-local logins to privileged accounts (group wheel).

 #

 # -:wheel:ALL EXCEPT LOCAL .win.tue.nl**

I changed it to:

+:wheel:ALL .win.tue.nl

and it worked.

  • Thank you very much that now looks like it did work. There are some things in the menubar (networking) and others that looked like it wasn't working. However, when I try the firewall app (for example), I can authenticate and use it remotely. Marking as the correct answer! – Ashley Aitken Aug 5 '14 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.