2

I already have emacs 24.1.1, but I need to use version 24.3. I tried:

sudo yum install emacs24.3

but it is not recognized. Is there a way to upgrade my emacs or should I simply install emacs 24.3? I also tried:

yum search emacs

but I could not find any related packages to emacs 24.3. I am using Fedora 17 (generic) on a VM.

BTW I am a bit new to Fedora, but familiar with Debian (particularly Ubuntu).

Update

Here are my Fedora version details:

-bash-4.2$ cat /etc/fedora-release 
Generic release 17 (Generic)
-bash-4.2$ 

Simply trying to install emacs does not work:

-bash-4.2$ sudo yum install emacs
Loaded plugins: langpacks, presto, refresh-packagekit
Package 1:emacs-24.1-7.fc17.x86_64 already installed and latest version
Nothing to do
-bash-4.2$ 
  • 1
    If you want software support for fedora, try running a supported release. fedoraproject.org/get-fedora Support for Fedora 17 ended 2013-07-30. – jsbillings Jul 20 '14 at 23:04
  • @jsbillings Good tip, thanks. I am using a VM for a class, and I need to replicate their environment, which unfortunately uses the outdated Fedora 17. – modulitos Jul 21 '14 at 7:21
1

You could always try to install the rpm from the later fedora versions. You can find them on rpmfind.net. Simply download the rpm matching your VM architecture and install using yum

yum localinstall emacs-24.3-18.fc21.x86_64.rpm

I'm not sure if you'll have the correct dependencies resolved. If so, you probably would have trouble compiling from source too. It can get pretty tricky when trying to update to a newer version of a piece of software than what is provided by the official repositories (because of all of the dependencies).

If yum only complains about a few missing dependencies, you may be able to also find and download those rpms as well. I've dealt with this sort of problem before. Sometimes it's relatively painless, and other times it's more trouble than it's worth.

Good luck!

1

With Fedora 17+, you can install emacs 24 simply:

sudo yum install emacs

You can search a package before install:

yum search emacs

Update

Refer to this link, it seems that emacs 24.3 is not include in Fedora 17 repository.

In this case, I think you should install emacs from source to get the newer version.

  • That does not work for installing emacs 24.3 (see my update above) – modulitos Jul 20 '14 at 21:18
  • Updated my answer. – cuonglm Jul 20 '14 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.