7

I just installed zorin 9 core (14.04) on my Hard-Disk in UEFI mode. But, when I boot, all that comes up is a GRUB2 command line. I've searched for solution and came up with this command

configfile (hd0,2)/boot/grub/grub.cfg

and it boots just fine. This command was from arch-linux and they said to copy the grub.cfg to the efi partition, but I don't know exactly what to copy or if I'm even in the right place. they also mentioned

"grub-mkimage"

but I'm not that much of an advanced user to get what all they were saying. could I just create a startup script that has that command in it? Here is the link - GRUB 2 showing prompt instead of menu.

2
  • so, does it boot successfully if you enter configfile (hd0,2)/boot/grub/grub.cfg on the prompt? what does ls give you? what does ls (hd0,1)/ or ls (hd0,2)/ give you?
    – noleti
    Jul 18 '14 at 13:42
  • Actually just create a grub.cfg file in /efi/ubuntu or whereever grub & shim files are. And add just that one configfile line to tell it to use grub.cfg in your install.
    – oldfred
    Jul 18 '14 at 14:36
1

Try these steps:

Step 1: Boot Ubuntu Live Media in UEFI Mode
Step 2: Mount Zorin OS partition on /mnt
Step 3: Mount EFI partition on /mnt/boot/efi
Step 4: Mount /dev/pts /dev/ /proc /sys /var/run /run on /mnt$i
Step 5: Chroot into /mnt
Step 6: Install grub2-efi, run grub2-mkconfig -o /boot/grub2/grub.cfg, run grub-install /dev/sda
Step 6: Done. Reboot.

I have done a dualboot Windows 8 and Zorin system myself.

A good video on how is here: https://www.youtube.com/watch?v=kHt3jij63o4

Note: Make sure UEFI in enabled in the Bios!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy