1

I have a program Vuze that is written in Java, which I use to download very large files, and I'm having a problem with it. I need to increase the amount of memory it uses. I've followed the directions for the application but it doesn't change the real memory usage. I would think this would then be because Java (JVM) is not set to support the amount of memory I set in the application.

I both get errors about files missing and low memory.

How can I increase the memory used by my Java Virtual Machine?

My Java is Oracle. My system is Fedora 20 X86_64 KDE.

2

You will need to modify the vuze shell script. This shell script is actually a link to a file called azureus, vuze's previous name. Within this script change the line JAVA_ARGS="-Xmx128m" to JAVA_ARGS="-Xmx256m", for example if you want to increase the memory to 256MB. Then restart vuze

  • do you see that message on console output when you run that sh ./azureus script? – Raza Jul 19 '14 at 11:50
  • The messages are a Vuze messages. They come in the lower right corner of the application. – somethingSomething Jul 19 '14 at 11:54
1

I found the solution to my problem here.

The workaround: I increased the memory used to 1024M with these instructions. I set the "Maximum files opened for read/write" to a 101. I ran the application from the command line with this command:

sudo bash -c 'ulimit -n 8192'; sudo -u username ./azureus
  • I set Vuze to run a different Java when I run it with this command from the commandline, the memory usage was unchanged if launch it with the application launcher. – somethingSomething Jul 27 '14 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.