I have been running dual boot windows7/ubuntu. Recently I reinstalled windows 7, and I no longer have the option to boot to ubuntu. I would like to be able to get my dual boot working again or at least be able to access that drive so that I can recover my data. These are some of the things that I have tried and their results.

I tried:

sudo grub-install --root-directory=/mnt/ /dev/sda

but that lost me the ability to boot from cd drive. ( can still boot from flash drive)

Eventually I tried boot-repair but It still boots directly to windows. It gave me the file: http://paste.ubuntu.com/7814117

When I do "restore the mbr of sda", it says:

partition booted by the MBR" sda1 (windows7(boot))

But none of my windows stuff should have been on sda. Is it possible that windows 7 installed its boot over my main ubuntu partition (or the ubuntu grub)? I also believe this may have happened because in the paste file, boot-repair says that my ex-linux partition is now "Boot sector type: Windows 7/2008: NTFS"

Any ideas?

My partition table looks like this:

$ sudo fdisk -l
/dev/sda1   *        2048   819202047   409600000    7  HPFS/NTFS/exFAT
/dev/sda2       819204094  1953523711   567159809    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5      1936891904  1953523711     8315904   82  Linux swap / Solaris

plus the windows stuff which is on /dev/sdb. My Ubuntu drive was sda1.

I did

$ sudo mount /dev/sda1 /mnt
$ sudo chroot /mnt
chroot: failed to run command `/bin/bash': No such file or directory

I also tried mounting sda1 under media, but that didn't work

ubuntu@ubuntu:/media$ sudo mount -t cifs -o ro /dev/sda1 /media/sda1
mount.cifs: bad UNC (/dev/sda1)
  • Related: unix.stackexchange.com/questions/47795/… – lgeorget Jul 18 '14 at 12:30
  • Could you explain us what have you tryed in what order explain better please because without more instruction we can't really help you – Kiwy Jul 18 '14 at 12:40
  • if noone can help me fix this, then can you guys tell me how to access the data in sda1 so that I can back up the important stuff? – Ivan Viti Jul 18 '14 at 17:42
  • @IvanViti You followed "all instructions". What instructions? This always happened when (re)installing Windows. Ubuntu is not gone, nor touched, only your boot menu cannot find it. First hits on Google always helped me to re-establish the boot menu. Therefore, you need to be really specific in what you tried. I suspect your case is not different. – Bernhard Jul 18 '14 at 19:22
  • 2
    Judging by the output of fdisk -l /dev/sda, your Linux partitions are gone. mount -t cifs doesn't make much sense, CIFS (a version of SMB) is a network file system used for accessing Microsoft shares. – peterph Jul 19 '14 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.