2

On many Linux distributions, be it BackTrack, Kali, BackBox, Ubuntu, Mint, etc., whenever I use anything from the aircrack-ng suite my wireless card is shown as channel -1. This problem has been around for years if I recall and I have never found a solution to it.

Why does this happen? What could I do to resolve this?

I have tried installing the latest backports to no avail, and I am unable to figure out how to apply this patch due to lack of available information on using it properly, nor do I even know if it will work due to how outdated it is.

Currently I am using the Alfa AWUS051NH wireless adapter with BackBox Linux 3.13 64-bit, but I have the same issue with the tried and true Alfa AWUS036H and other Linux distributions. Here's some hopefully helpful info:

backbox@backbox-vm:~$ uname -r
3.11.0-26-generic
backbox@backbox-vm:~$ lsusb
Bus 001 Device 002: ID 148f:2770 Ralink Technology, Corp. RT2770 Wireless Adapter
backbox@backbox-vm:~$ lsmod | grep rt2
rt2800usb              27225  0 
rt2800lib              81972  1 rt2800usb
crc_ccitt              12707  1 rt2800lib
rt2x00usb              20886  1 rt2800usb
rt2x00lib              56180  3 rt2800usb,rt2800lib,rt2x00usb
mac80211              623710  3 rt2800lib,rt2x00usb,rt2x00lib
cfg80211              499466  2 rt2x00lib,mac80211
3

Try this from the Ask Ubuntu section:
https://askubuntu.com/questions/318583/how-can-i-solve-fixed-channel-1-mon0-is-on-channel-1-issue-when-using-airo
The lastest dev version has the --ignore-negative-one option.
Obtain the lastest dev version from subversion:
Install Subversion: On Debian/Ubuntu: sudo apt-get install subversion
Then, obtain it via svn. On Debian/Ubuntu:

sudo svn co http://svn.aircrack-ng.org/trunk/ aircrack-ng

Then cd aircrack-ng
Then sudo make
Finally:sudo make install if you'd like to install it immediately, though I'd suggest you test the binaries first. Try running them with the --ignore-negative-one option.

1
  • I agree with this answer because I have had this problem several times, but in my case, the -1 channel has disappeared just by installing the latest version, no need to use the --ignore-negative-one option. I can even say that I did not need to install the SVN latest development one. Aug 1 '15 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.