Can I replace my openssl 0.9.8o-4squeeze16 package with http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_1.0.1h-3_amd64.deb without any problems/concers? I did a apt-get update but I did not get a higher version than 0.9.8o-4squeeze16. Is there anything I should think about before installing it with apt-get install openssl_1.0.1h-3_amd64.deb ?

  • Is there a particular reason why you need to run the squeeze release? "Wheezy" is the current stable release you understand, and has openssl version 1.0.1e. Check your /etc/apt/sources.list for references to squeeze if you just want the current stable release – Geeb Jul 17 '14 at 16:57

Debian squeeze is no longer current, so you can't expect recent versions of programs to be available for it. If you really need the openssl command line tool, you could recompile it, but do consider whether you really need that: there aren't that many new features. There are still security updates for squeeze, if that's what you're concerned about.

If you have a program that is compiled with version 1.0.x of the OpenSSL library, you can install a libssl1.0.0 package (alongside the libssl0.9.8 package that comes with the distribution). There's no official binary, but downloading the source from wheezy or jessie and recompiling the package on a squeeze machine should work.

  • Thanks for your anwser - cant I just install the .deb with apt-get install? Or are there any incompatibilities? – jsterr Jul 18 '14 at 6:21
  • @jonas In order to install with apt-get install, you'd have to find a source that provides this package for squeeze. There's no official source, there might be an unofficial one somewhere. If you compile manually, you can install with dpkg -i. – Gilles Jul 18 '14 at 6:53
  • so wget http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_1.0.1h-3_amd64.deb and dpkg -i openssl_1.0.1h-3_amd64.deb but I just want to know, if everything will work fine after upgrading openssl from to the version (1.01h-3). – jsterr Jul 18 '14 at 7:22
  • 1
    @jonas You'll need to install the libssl1.0.0 package since the openssl tool uses the libssl library and unsurprisingly requires a matching version. Furthermore you'll need to recompile them (they're from the same source package, openssl) because the packages in jessie are compiled for a more recent C library than what you have on squeeze. Again, are you sure you need to install a very recent version of OpenSSL on such an old system? – Gilles Jul 18 '14 at 7:24
  • 1
    Do nod try to mix binaries from different distribution versions. You'll wind up breaking lots of stuff. – Shadur Jan 10 '15 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.