7

I have set up "new email notification" in my Thunderbird, both "Show an alert" and "Play a sound", as shown below. But now I am experiencing strange problems.

The sound only works sometimes. Then, I close Thunderbird and start again, and there is 50% chance that the sound will not work. If I keep restarting Thunderbird, eventually the sound will start to work again.

The wav file exists, when I click on Play I can hear the sound.

enter image description here

I have a suspicion, this problem might be connected to the fact, that I have two Thunderbird Profiles which I am using simultaneously. Sometimes the Notification works in both, sometimes in one only. The problem is with both the sound notification and the "Show an Alert" notification.

I use following commands to start the two profiles, respectively:

icedove -P "default"
icedove -P "second" -no-remote

The problem with the notification happens in a non-deterministic way. Even when only one profile is running, the notifications might not work (thus, the problem is not caused by one instance "blocking" the device/resource).

How could I fix this problem? New mail notifications are crucial for my workflow. This problem is critical for me.

I am using Thunderbird (Icedove) 24.6.0

UPDATE:

I did some further troubleshooting: When I am monitoring access to the wav file using inotify, I see that upon new message, no process is attempting to open new_mail.wav:

while inotifywait new_mail.wav ; do echo "$(date +%T) inotify event" ; done

When I click on the Play button however, the sound actually plays, I and get the inotify events as well.

This looks like some bug in Thunderbird, where an event (new email) is not properly recognized and acted upon.

  • does the server sound (alsa or other) busy while thunderbird receives a new message? – Pol Hallen Jul 26 '14 at 19:43
1

This is an alternative solution to play the sound file and show a notification on the desktop.

Create a small shell script that will contain the commands to be run when a new email arrives:

#!/bin/sh

if [ $1 = true ]; then
    aplay new_mail.wav
    notify-send --icon=icedove Icedove 'There are new emails!'
fi

Save the script and make it executable:

chmod +x /path/to/script.sh

Install the extension FireTray, then go to its settings. On the tab Mail, place the full path to the script in Launch on count change.

Some notes:

  • The script will be called by FireTray either with the argument true or false. The argument will be true if there's new mail.
  • aplay comes from the package alsa-utils, and should be installed by default. If you use PulseAudio, you can use paplay instead, from the package pulseaudio-utils, but aplay is supposed to work with PulseAudio too.
  • notify-send needs the package libnotify-bin.
  • I would prefer to make use of the existing notification infrastructure in Thunderbird. I don't want to install yet another addon, only to fix something that should work. Besides, this addon does many things, which I don't need (and like). – user1968963 Jul 22 '14 at 9:18
  • @user1968963 You have found a bug in Thunderbird, so beware Thunderbird is more in maintenance mode nowadays, so don't expect it to be fixed soon. I answered with this alternative because you said notifications are crucial to your workflow. If that's really the case, I don't see the problem of installing one addon, but that's up to you. – Teresa e Junior Jul 22 '14 at 17:28
1

I always keep Thunderbird open in one of my monitors, this seems to keep it from properly notifying me of new messages via the sound or the popup. I found this plugin: Mailbox Alert to be very helpful. It allows for extra customization of new mail alerts, even different ones for different folders.

  • Installing your suggested extension finally worked for me in Linux Mint 17.3 (rosa). Why in the bloody hell do I need to install an extension to get something as simple as a sound notification in my email client to work is beyond stupid. – RyanNerd Jan 8 '16 at 0:00
0

Is your email account configured as an IMAP account? If yes, it is using a feature called "condstore" which is supposed to better coordinate activities when the account is accessed from multiple locations. It is known to be buggy though on Thunderbird's side and may miss incoming mails in this way.

The workaround is to disable that feature:

  • On Windows, enter the Options window from either the ≡ application button or the Tools menu;
  • Go into the Advanced tab and find the "Config Editor" in its General tab;
  • Enter condstore into the search bar on top of the about:config window;
  • Double-click on all mail.server.something.use_condstore entries to toggle them to "false" (as a minimum, this should be the "default" entry;
  • Restart Thunderbird and see if it fixes the problem.

I took this from https://support.mozilla.org/en-US/questions/991323#answer-547366

  • thank you, but I think I need the "condstore" feature, because I am accessing my account from several clients – user1968963 Jul 25 '14 at 7:40
  • I think that is the problem then, Thunderbird is not seeing the mail as a "New mail" rather one that has been accessed by another client already – Rqomey Jul 25 '14 at 12:03
  • no. Thunderbird receives new message, displays it as new in inbox, but fails to execute the notify action. Besides, the problem exists even when only one client is accessing the server/account. – user1968963 Jul 25 '14 at 12:35
0

Same issue - using Ubuntu 16.04 TB 45.4.0

-TB does receive new mail and show it as new in inbox in bold -Sound is configured properly in settings -Wasnt too thrilled about FireNotify

Installing Mailbox Alert fixed the issue for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.