1

I updated my Debian installation at home and it updated chromium to the (IMO) awfull 35.0 version. I removed it by using apt-get remove chromium and apt-get autoremove. I went here and grabbed the .deb for the 34.0 version I had previously installed. I used dpkg -i filename.deb to install it, but there were unmet dependencies:

dpkg: dependency problems prevent configuration of chromium:
 chromium depends on libc6 (>= 2.15); however:
  Version of libc6:amd64 on system is 2.13-38+deb7u3.
 chromium depends on libfontconfig1 (>= 2.11); however:
  Version of libfontconfig1:amd64 on system is 2.9.0-7.1.
 chromium depends on libgcrypt20 (>= 1.6.1); however:
  Package libgcrypt20 is not installed.
 chromium depends on libglib2.0-0 (>= 2.37.3); however:
  Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.
 chromium depends on libpango-1.0-0 (>= 1.22.0); however:
  Package libpango-1.0-0 is not installed.
 chromium depends on libpangocairo-1.0-0 (>= 1.14.0); however:
  Package libpangocairo-1.0-0 is not installed.
 chromium depends on libudev1 (>= 183); however:
  Package libudev1 is not installed.
 chromium depends on chromium-inspector; however:
  Package chromium-inspector is not installed.

Which I thought was odd, since it claims some libraries are "too old", even though I just updated the system (and chromium, which I assume depends on those libraries being in their latest version too).

Anyway I used apt-get -f install to fix them, but apt "fixed" it by updating the package to the latest version (35.0) and downloading the dependencies in their latest version too.

So... Is there a way to automatically fix those dependencies without updating chromium to 35.0, or do I have to download every dependency in their "correct" version? Wouldn't that cause some conflicts?

2

Turns out I only needed to install chromium-inspector (not to be confused with chromium-browser-inspector) and chromium. For some reason it "fixed" the other dependencies.

The procedure was the following:

  • Export bookmarks to a .html file (via Chromium's Bookmark Manager)
  • Backup configs (cp -r ~/.config/chromium BAK)
  • apt-get purge chromium
  • apt-get autoremove (to remove chromium-inspector)
  • rm -rf ~/.config/chromium (because the profile was updated to 35.0 and conflicts with 34.0)
  • Download chromium_34.0 and chromium-inspector_34.0 (links for amd64).
  • cd into the download folder and dpkg -i $(ls | grep -i inspector) and then dpkg -i $(ls | grep -i amd) (for amd64)
  • Finally, apt-mark hold chromium and apt-mark hold chromium-inspector
  • Import the exported bookmarks and re-download extensions, etc.
1

You want to hold that package at it's current version. Make sure you have apt-mark installed. After installing chromium version 34, use this command

apt-mark hold chromium

Then rerun

apt-get install -f
  • Thanks! However, I'm now getting an error when trying to fix the dependencies. – Alex Jul 16 '14 at 21:44
  • It looks like you have several packages that are not installable for some reason, libgcrypt20 (>= 1.6.1), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libudev1 (>= 183). They may no longer be available for download. I would use aptitude to see if it can resolve the dependencies. It's never easy to go backwards in packages. :( – Sepero Jul 16 '14 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.