Firstly, sorry if there is something unclear in my question but English is not my native language and I will correct the question if needed. Here is my problem:

I have a notebook with ATI RADEON (venus pro) HD 8850M dedicated GPU and intel HD 4400 GPU. I have installed Intel GPU drivers successfully by modifying /etc/lsb-release and using their GUI (Intel(R) Graphics Installer).

However i have had no success installing AMD drivers. After clean Mint Linux 17 xfce install (no Intel drivers) I downloaded the linux x64 drivers from AMD's website. I have executed the *.run file, some GUI wizard showed up and I tried to install drivers but then I got the message Your graphics adapter is not supported by this driver. Installation will not proceed.. Then I downloaded the latest beta version of the driver and tried the same but again I got the message Your graphics adapter is not supported by this driver.....

I have searched for the message above and I have read that AMD dropped support for many of their products and that might be the reason I get it. However ATI HD 8850M was released in 2013 so is it possible AMD to have dropped driver support?

Anyway I decided to try another approach. I have used the Synaptic package manage and installed fglrx, fglrx-amdcccle and fglrx-pxpress. Then I rebooted and after reboot I was able to start the Catalyst Control Center. I have used GUI program called "Hardinfo" to check if AMD GPU was running instead and it was running. I have checked also in google chrome chrome://gpu to see if hardware acceleration worked and it worked. Everything seemed to be OK.

Next I used CCC to switch graphics to the Integrated Intel GPU and rebooted. It could not boot correctly first time. Mint logo showed up but after it disappeared nothing more happened except that I could see the screen black with backlight on, heat started to build up rapidly and fans accelerated. I have waited more than 5 minutes to boot after the screen was black but nothing happened. Next time it started normally and using hardinfo I could see that Intel GPU was used. Checked chrome://gpu and hardware acceleration worked too.

I have succesfully started Catalyst CC, switched to AMD graphics and rebooted without problems. When I checked what hardinfo was saying I saw Intel GPU was used and not AMD (I switched to it before restart). Then I tried to open Catalyst CC but I had no success. I tried to run it using cli as I have successfully done before (sudo amdcccle) but I got command not found. When I checked /usr/lib/fglrx everything was there so I tried to run amdcccle and I got the message that I had no compatible graphics (or something similar) and i t refused to start up. Synaptic package manage showed that fglrx, fglrx-amdcccle ... were installed so I removed them completely, rebooted and tried to install them again. However I could not start Catalyst again normally. sudo amdcccle still results in command not found and if I run it from/usr/lib/fglrx` it says i have no compatible device or sth...

I also tried to install the "fglrx-update, fglrx-amdcccle" combo instead but I had the same experience.

The last thing I tried was using Mint Linux's "Driver Manager" GUI and it shows three options: "xserver-xorg-video-ati" which is the recommended option and "fglrx" and "fglrx-update".

Is there any way to install both Intel and AMD graphics drivers and be able to switch GPUs when I want? Why I was unable to start Catalyst CC normally after switching to Intel HD 4400 and back? Why command not found? Was it removed from the path variable after the reboot and why? Have AMD dropped the support for ATI Radeon HD 8850 and if they have stopped supporting it what could I do?

closed as too broad by Braiam, Networker, jimmij, Anthon, Michael Homer Jan 2 '15 at 22:11

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Some very quick Googling revealed this article. Does this help: community.linuxmint.com/tutorial/view/1501 – ewhac Jul 16 '14 at 18:39
  • 1
    There is a very well written blog about this here If you still run into issues I'll start experimenting on my own laptop. – Foosh Oct 30 '14 at 22:59
  • 1
    hardware support is not distribution-related, so Switching to an other Linux is the last thing I would do in your situation. I myself also had problems with the Intel driver, but other than the one you have, so I cant help you with the problem, I only wanted to say if you like the distribution you are on now, stick with it, underneath the visible changes all Linuxes are basically the same. – switch87 Nov 4 '14 at 22:14
  • 1
    Does this Gentoo Forum Post lead in the right direction? – eyoung100 Dec 2 '14 at 23:01
  • 1
    Have you tried omega catalyst drivers? you just download packages that you need and run sudo dpkg -i *.deb – kirill-a Dec 25 '14 at 5:51