1

I have tried to install Gimp on my Ubuntu 14.04, but I encountered an error:

root@vitor-pc:~# LANG=C apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@vitor-pc:~# LANG=C apt-get install gimp 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gimp : Depends: libgegl-0.2-0 (>= 0.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And I already to tried this solution How do I resolve unmet dependencies?.

However, I still get the above message.

How can I fix this?


apt-cache policy <package>:

vitor@vitor-pc:~$ LANG=C apt-cache policy gimp libgegl-0.2-0
gimp:
Installed: (none)
Candidate: 2.8.10-0ubuntu1
Version table:
    2.8.10-0ubuntu1 0
    500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
    2.8.10-0trusty4~ppa 0
    500 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/   trusty/main i386 Packages
     2.8.8~trusty~NoobsLab.com 0
    500 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ trusty/main i386   Packages
    libgegl-0.2-0:
    Installed: (none)
    Candidate: 0.2.1-3~trusty~Noobslab.com
    Version table:
    0.2.1-3~trusty~Noobslab.com 0
    500 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ trusty/main  i386    Packages
 0.2.0-4ubuntu1 0
    500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

apt-cache policy:

root@vitor-pc:~# LANG=C apt-cache policy
Package files:
100 /var/lib/dpkg/status
 release a=now
 500 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/ trusty/main i386  Packages
 release v=14.04,o=LP-PPA-otto-kesselgulasch-gimp,a=trusty,n=trusty,l=gimp,c=main
 origin ppa.launchpad.net
 500 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-noobslab-ppa-gimp,a=trusty,n=trusty,l=Gimp,c=main
 origin ppa.launchpad.net
 500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-libreoffice,a=trusty,n=trusty,l=LibreOffice PPA,c=main
 origin ppa.launchpad.net
 500 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-kubuntu-ppa-backports,a=trusty,n=trusty,l=Kubuntu Backports,c=main
 origin ppa.launchpad.net
500 http://ppa.launchpad.net/irie/blender/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-irie-blender,a=trusty,n=trusty,l=PPA for Blender  2.4 and 2.7,c=main
 origin ppa.launchpad.net
500 http://ppa.launchpad.net/inkscape.dev/trunk/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-inkscape.dev-trunk,a=trusty,n=trusty,l=Inkscape Trunk,c=main
 origin ppa.launchpad.net
500 http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages
 release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
 origin dl.google.com
500 http://extras.ubuntu.com/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=LP-PPA-app-review-board,a=trusty,n=trusty,l=Application Review Board PPA,c=main
 origin extras.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-security/universe Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-security/restricted Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-security/multiverse Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-security/main Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-security/multiverse i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=multiverse
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-security/universe i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=universe
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-security/restricted i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=restricted
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=main
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-backports/universe Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-backports/restricted Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-backports/multiverse Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-backports/main Translation-en
100 http://archive.ubuntu.com/ubuntu/ trusty-backports/multiverse i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=multiverse
 origin archive.ubuntu.com
100 http://archive.ubuntu.com/ubuntu/ trusty-backports/universe i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=universe
 origin archive.ubuntu.com
100 http://archive.ubuntu.com/ubuntu/ trusty-backports/restricted i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=restricted
 origin archive.ubuntu.com
100 http://archive.ubuntu.com/ubuntu/ trusty-backports/main i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=main
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/restricted Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/multiverse Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/multiverse i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=multiverse
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=universe
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/restricted i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=restricted
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
 release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=main
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty/universe Translation-pt_BR
500 http://archive.ubuntu.com/ubuntu/ trusty/universe Translation-pt
500 http://archive.ubuntu.com/ubuntu/ trusty/universe Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty/restricted Translation-pt_BR
500 http://archive.ubuntu.com/ubuntu/ trusty/restricted Translation-pt
500 http://archive.ubuntu.com/ubuntu/ trusty/restricted Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty/multiverse Translation-pt_BR
500 http://archive.ubuntu.com/ubuntu/ trusty/multiverse Translation-pt
500 http://archive.ubuntu.com/ubuntu/ trusty/multiverse Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty/main Translation-pt_BR
500 http://archive.ubuntu.com/ubuntu/ trusty/main Translation-pt
500 http://archive.ubuntu.com/ubuntu/ trusty/main Translation-en
500 http://archive.ubuntu.com/ubuntu/ trusty/multiverse i386 Packages
 release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=multiverse
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
 release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=universe
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty/restricted i386 Packages
 release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=restricted
 origin archive.ubuntu.com
500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
 release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=main
 origin archive.ubuntu.com
 Pinned packages:
  • Please paste the output of apt-cache policy gimp libgegl-0.2-0 into your question. The output of apt-cache policy would also be helpful. Using screenshots is not optimal. For example, one cannot cut and paste from them. – Faheem Mitha Jul 16 '14 at 15:24
  • Please don't post screenshots of your terminal. Just copy/paste the text directly into your question. You can use the formatting tools to make it look good. Adding an image i) makes it hard for us to help since we can't just copy/paste the commands you ran to test, ii) makes the page slower to load for no reason and iii) makes it even harder for visually impaired users. – terdon Jul 16 '14 at 15:28
  • 1
    Please do LANGUAGE=en, then run sudo apt-get install gimp again, so we can see English output. Post this output instead of a picture. – polym Jul 16 '14 at 15:28
  • 1
    Run, copy and paste the output of LANG=C apt-get -f install. Also apt-cache policy gimp libgegl-0.2-0. – Braiam Jul 16 '14 at 15:30
  • 1
    @VitorMazuco the problem is the PPA needs to be pinned or removed. – Faheem Mitha Jul 16 '14 at 15:56
4

You have two PPAs, probably in your /etc/apt/sources.list. They are

deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/ trusty/main i386  
deb http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ trusty/main i386 

These both look like GIMP PPAs, but since they are equal to or less than the version of the official PPA, there is no point to them. So, take them out.

The immediate problem you are facing is as a side-effect of one of these PPAs, the noobslab one. This has a version of libgegl-0.2-0 which is more recent (0.2.1-3~trusty~Noobslab.com) than the one in Ubuntu itself (0.2.0-4ubuntu1). For reasons that are not clear to me, this is preventing libgegl-0.2-0 from being installed.

If you want to diagnose this further (you probably don't) you could run

apt-get install libgegl-0.2-0

without changing anything, and see what output you get.

  • Where and how I have to remove? – Vitor Mazuco Jul 16 '14 at 16:02
2

I don't know if your problem still exists, but in case it does I've found a solution which worked for me (Xenial 16.04):

Link to ubuntuforums.org

The user proposes to use aptitude instead of apt-get for installing gimp.

sudo apt-get install aptitude
sudo aptitude update
sudo aptitude install gimp

When I installed it that way I was asked for some error treatment proposals in the terminal (which I cannot show here anymore unfortunately...). The first one I neglected (entering "n" when asked), but the second one I accepted (entering "y" when asked) - and that worked.

Some packages have been downgraded, dependencies have been solved and Gimp has been installed successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.