I've installed udisks-glue on my Raspbian Raspberry Pi, along with a System V init script at /etc/init.d/udisks-glue (as per instructions here). I make it executable and run the following, which returns no errors.

sudo update-rc.d udisks-glue defaults

I can start the script fine, and it works as expected.

$ sudo service udisks-glue start
[ ok ] Starting Automounter: udisks-glue.
$ sudo service udisks-glue status
[ ok ] udisks-glue is running.

However, when I reboot, it's not running. This used to work fine, but I reinstalled a minimal system, and it no longer works. It's possible that I'm missing some packages.

$ sudo service udisks-glue status
[FAIL] udisks-glue is not running ... failed!


I've tried to log output and errors by changing a line in the start) block to

start-stop-daemon --start --exec $DAEMON -- -p $PIDFILE &>> /tmp/udisks-glue.log

This file is empty on reboot. However, it does exist, suggesting that the script is at least partially executed.

Finally, I've tried to confirm proper installation. Amongst other things, locate udisks-glue returns


EDIT — Further troubleshooting

I thought I might test if the script was acting too early, so I tested two possible solutions. Both failed. Firstly, I tried making the script run at a lower priority.

mv /etc/rc2.d/S{01,90}udisks-glue

Secondly, I reverted this then inserted sleep 90 into the start) block, just before the start-stop-daemon invocation.

2 Answers 2


It sounds like your Rasp Pi device is running in a runlevel other than 2, 3, 4, or 5, given your /etc/rc*.d directories contain links to your udisks-glue script. The way you can tell this is the links that start with a K will kill your script/service when in one of those runlevels while an S will start it.

I'd double check your runlevel and then adjust the link in the corresponding runlevel's directory.

What's my runlevel

You can typically run this command to find this out.

$ runlevel
N 5

So my system is in runlevel 5.

  • runlevel returns N 2. I can see /etc/rc2.d/S01udisks-glue exists, so does that mean that it should have been running? (Also, from the previously-linked script, # Default-Start: 2 3 4 5)
    – Sparhawk
    Jul 16, 2014 at 6:59
  • @Sparhawk - that looks correct, I had a typo in the A, 2 should be starting the script.
    – slm
    Jul 16, 2014 at 7:09
  • No worries, I suspected this, and assumed it was a typo. :) I guess this is a dead end, though. Thanks for the answer anyway.
    – Sparhawk
    Jul 16, 2014 at 7:10
  • @Sparhawk - does the log file exist when you go looking for it? That would imply that your script ran and nothing was put into it. If it doesn't exist then the script didn't even run.
    – slm
    Jul 16, 2014 at 7:25
  • Yes, it exists, but is empty.
    – Sparhawk
    Jul 16, 2014 at 7:26

I had the same problem, then I went to

cd /etc/init.d/

and gave the udisks-glue to root

 sudo chown root: udisks-glue

an tried it with

sudo reboot

And it worked like a charme!

  • As per the instructions linked in the question, I ran sudo cp udisks-glue /etc/init.d/., which already makes this script owned by root. (The -1 wasn't me.)
    – Sparhawk
    Jul 23, 2014 at 0:43
  • I also had some issues with copying the script. I got it then with git and it worked. I do not remember what issue. May be one more try... Otherwise I have no ideas.
    – MAWSpitau
    Jul 23, 2014 at 6:22
  • I've tried it several times, with both copy-paste and git. As per the question, (I think) I had it working before I created the minimal install, so perhaps it's missing packages. Thanks anyway.
    – Sparhawk
    Jul 23, 2014 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .