2

I have one custom Linux board on which I want to run apache web server to test HTML and other web based services.

I have configured, cross compiled and installed default httpd (2.2.24, 2.4.1, 2.4.4 and 2.4.9) on my Linux PC (Ubuntu 12.04 LTS) as well as on my own custom Linux board. Then I have added support of SSL Module (mod_ssl) to test HTTP as well as HTTPS request.

Both HTTP and HTTPS request works fine without any issue on my Linux PC (Ubuntu 12.04 LTS). But when I tried to execute same HTTP request on my Linux Board using httpd (2.4.4 and 2.4.9) at that time browser page goes into loading state and can not be came out from that situation after enabling SSL module. Also I have seen that HTTPS request works fine at that time.

I have also did some debugging task through wire-shark tool and found that connection is established successfully after sending request through HTTP but can not get response of that request. I have also found that response of that HTTP request received on wire-shark after closing that HTTP requested page from browser.

Also, I can run HTTP and HTTPS requests successfully using httpd (2.2.24 and 2.2.27) on my Linux Board but failed to execute same request using httpd (2.4.X) package.

I have also changed some configurations by creating different virtual host for HTTP (Port 80) and HTTPS (Port 443) but still failed to execute that HTTP request.

I have also tried to listen on different ports like (Listen 80 and Listen 8000) without SSL module (using httpd 2.4.4. and 2.4.9 ) at that time HTTP request goes into loading state.

Can anyone has idea about this issue or help me to solve this type of issue?

  • Please let me know if anyone has idea about this issue. I can not even send single request after listening on multiple ports for httpd (2.4.X). But I can single HTTP request after listening on multiple ports for httpd (2.2.X). – Ritesh Prajapati Jul 17 '14 at 4:18
  • I have also disabled all extra modules and started with basic modules then still http request failed after listening on multiple ports. Loaded Modules: core_module (static) so_module (static) http_module (static) mpm_worker_module (static) authz_core_module (shared) unixd_module (shared) dir_module (shared) – Ritesh Prajapati Jul 17 '14 at 7:21
  • does any one has idea about this issue or faced this type of issue before? – Ritesh Prajapati Jul 18 '14 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.