1

I created a minimal install on my Raspbian Raspberry Pi running Debian Jessie. Among other things, I removed libx11-.* and dependencies, which included removal of policykit-1. I'm trying to reinstall policykit-1, but hit the following errors.

$ sudo apt-get install policykit-1
...
The following packages will be REMOVED:
  sysvinit-core
...
dpkg: sysvinit-core: dependency problems, but removing anyway as you requested:
 sysvinit depends on sysvinit-core | upstart | systemd-sysv; however:
  Package sysvinit-core is to be removed.
  Package upstart is not installed.
  Package systemd-sysv is not installed.

After this, booting now hangs, and I have to restore the SD card to an image before this install command. (N.B. booting worked fine before the creation of the minimal install, and after the removal of libx11-.* and dependencies.) How can I reinstall policykit-1?


Edit

This worked for a little while, but no longer.

There is a long thread here discussing how policykit-1 can break your system in Debian. I didn't read it all, but this (closed) bug report suggests that systemd-shim might be helpful.

Running the following command allowed me to reboot the computer, although I'm unsure as to how functional policykit-1 is.

sudo apt-get install systemd-shim policykit-1

However, a recent update to Debian Jessie prevents this from working. policykit-1 was uninstalled after sudo apt-get dist-upgrade, and running this command still asks you to uninstall sysvinit-core.

8
  • Please provide the output of apt-rdepends -r policykit-1
    – eyoung100
    Jul 17, 2015 at 0:33
  • 1
    If that doesn't work try: apt-cache --installed rdepends policykit-1
    – eyoung100
    Jul 17, 2015 at 0:38
  • @eyoung100 Only the seconds works, with udisks libpolkit-gobject-1-0
    – Sparhawk
    Jul 20, 2015 at 14:21
  • My hunch here is that the packages need to be reinstalled in the proper order. Remove udisks and libpolkit-gobject then reinstall policykit-1. Policykit-1 should reinstall sysvinit-core and sysvinit. You may need to do this in rescue mode, as X may no longer work.
    – eyoung100
    Jul 20, 2015 at 16:31
  • @eyoung100 As per the question, I don't have X installed. I also don't understand how the order of installation might help here, as (AFAIK) there are no conflicting files installed across the packages. Also, as per the question, policykit-1 seems to require the removal of sysvinit-core, so I'm not sure why we'd expect it to reinstall sysvinit-core instead? (It's non-trivial to restore my system when it breaks, so I'd prefer more certain answers.)
    – Sparhawk
    Jul 25, 2015 at 4:54

1 Answer 1

0

For more recent readers:

Devuan is a distribution which uses sysvinit by default and includes a policykit-1 package that does not depend on systemd. It is mostly compatible with Debian in nearly every respect that does not deal with the init system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.